mirror of https://github.com/hak5/openwrt.git
27 lines
860 B
Diff
27 lines
860 B
Diff
--- a/drivers/gpio/Kconfig
|
|
+++ b/drivers/gpio/Kconfig
|
|
@@ -489,4 +489,13 @@ config GPIO_TPS65910
|
|
help
|
|
Select this option to enable GPIO driver for the TPS65910
|
|
chip family.
|
|
+
|
|
+comment "Other GPIO expanders"
|
|
+
|
|
+config GPIO_NXP_74HC153
|
|
+ tristate "NXP 74HC153 Dual 4-input multiplexer"
|
|
+ help
|
|
+ Platform driver for NXP 74HC153 Dual 4-input Multiplexer. This
|
|
+ provides a GPIO interface supporting input mode only.
|
|
+
|
|
endif
|
|
--- a/drivers/gpio/Makefile
|
|
+++ b/drivers/gpio/Makefile
|
|
@@ -35,6 +35,7 @@ obj-$(CONFIG_GPIO_MSM_V2) += gpio-msm-v2
|
|
obj-$(CONFIG_GPIO_MXC) += gpio-mxc.o
|
|
obj-$(CONFIG_GPIO_MXS) += gpio-mxs.o
|
|
obj-$(CONFIG_PLAT_NOMADIK) += gpio-nomadik.o
|
|
+obj-$(CONFIG_GPIO_NXP_74HC153) += gpio-nxp-74hc153.o
|
|
obj-$(CONFIG_ARCH_OMAP) += gpio-omap.o
|
|
obj-$(CONFIG_GPIO_PCA953X) += gpio-pca953x.o
|
|
obj-$(CONFIG_GPIO_PCF857X) += gpio-pcf857x.o
|