mirror of https://github.com/hak5/openwrt.git
26 lines
963 B
Diff
26 lines
963 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -283,6 +283,12 @@ config SPI_PXA2XX
|
|
The driver can be configured to use any SSP port and additional
|
|
documentation can be found a Documentation/spi/pxa2xx.
|
|
|
|
+config SPI_RAMIPS
|
|
+ tristate "Ralink RT288x/RT305x SPI Controller"
|
|
+ depends on (SOC_RT288X || SOC_RT305X) && SPI_MASTER
|
|
+ help
|
|
+ This selects a driver for the Ralink RT288x/RT305x SPI Controller.
|
|
+
|
|
config SPI_S3C24XX
|
|
tristate "Samsung S3C24XX series SPI"
|
|
depends on ARCH_S3C2410 && EXPERIMENTAL
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -37,6 +37,7 @@ obj-$(CONFIG_SPI_FSL_LIB) += spi_fsl_li
|
|
obj-$(CONFIG_SPI_FSL_ESPI) += spi_fsl_espi.o
|
|
obj-$(CONFIG_SPI_FSL_SPI) += spi_fsl_spi.o
|
|
obj-$(CONFIG_SPI_PPC4xx) += spi_ppc4xx.o
|
|
+obj-$(CONFIG_SPI_RAMIPS) += ramips_spi.o
|
|
obj-$(CONFIG_SPI_S3C24XX_GPIO) += spi_s3c24xx_gpio.o
|
|
obj-$(CONFIG_SPI_S3C24XX) += spi_s3c24xx_hw.o
|
|
obj-$(CONFIG_SPI_S3C64XX) += spi_s3c64xx.o
|