mirror of https://github.com/hak5/openwrt.git
27 lines
1.1 KiB
Diff
27 lines
1.1 KiB
Diff
Index: linux-2.6.32.9/scripts/Makefile.lib
|
|
===================================================================
|
|
--- linux-2.6.32.9.orig/scripts/Makefile.lib 2010-04-13 07:55:06.543296524 +0200
|
|
+++ linux-2.6.32.9/scripts/Makefile.lib 2010-04-13 07:55:06.814268461 +0200
|
|
@@ -228,7 +228,7 @@
|
|
|
|
quiet_cmd_lzma = LZMA $@
|
|
cmd_lzma = (cat $(filter-out FORCE,$^) | \
|
|
- lzma e -d20 -lc1 -lp2 -pb2 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
|
+ lzma e -lc8 -eos -si -so && $(call size_append, $(filter-out FORCE,$^))) > $@ || \
|
|
(rm -f $@ ; false)
|
|
|
|
quiet_cmd_lzo = LZO $@
|
|
Index: linux-2.6.32.9/arch/x86/include/asm/boot.h
|
|
===================================================================
|
|
--- linux-2.6.32.9.orig/arch/x86/include/asm/boot.h 2010-02-23 16:38:51.000000000 +0100
|
|
+++ linux-2.6.32.9/arch/x86/include/asm/boot.h 2010-04-13 08:00:14.474369306 +0200
|
|
@@ -28,7 +28,7 @@
|
|
#error "Invalid value for CONFIG_PHYSICAL_ALIGN"
|
|
#endif
|
|
|
|
-#ifdef CONFIG_KERNEL_BZIP2
|
|
+#if defined(CONFIG_KERNEL_BZIP2) || defined(CONFIG_KERNEL_LZMA)
|
|
#define BOOT_HEAP_SIZE 0x400000
|
|
#else /* !CONFIG_KERNEL_BZIP2 */
|
|
|