mirror of https://github.com/hak5/openwrt.git
85 lines
3.1 KiB
Diff
85 lines
3.1 KiB
Diff
Index: linux-2.6.25.4/drivers/char/Makefile
|
|
===================================================================
|
|
--- linux-2.6.25.4.orig/drivers/char/Makefile
|
|
+++ linux-2.6.25.4/drivers/char/Makefile
|
|
@@ -112,6 +112,12 @@ obj-$(CONFIG_PS3_FLASH) += ps3flash.o
|
|
obj-$(CONFIG_JS_RTC) += js-rtc.o
|
|
js-rtc-y = rtc.o
|
|
|
|
+obj-$(CONFIG_IFXMIPS_LED) += ifxmips_led.o
|
|
+obj-$(CONFIG_IFXMIPS_GPIO) += ifxmips_gpio.o
|
|
+obj-$(CONFIG_IFXMIPS_SSC) += ifxmips_ssc.o
|
|
+obj-$(CONFIG_IFXMIPS_EEPROM) += ifxmips_eeprom.o
|
|
+obj-$(CONFIG_IFXMIPS_MEI) += ifxmips_mei_core.o
|
|
+
|
|
# Files generated that shall be removed upon make clean
|
|
clean-files := consolemap_deftbl.c defkeymap.c
|
|
|
|
Index: linux-2.6.25.4/drivers/mtd/maps/Makefile
|
|
===================================================================
|
|
--- linux-2.6.25.4.orig/drivers/mtd/maps/Makefile
|
|
+++ linux-2.6.25.4/drivers/mtd/maps/Makefile
|
|
@@ -68,3 +68,4 @@ obj-$(CONFIG_MTD_PLATRAM) += plat-ram.o
|
|
obj-$(CONFIG_MTD_OMAP_NOR) += omap_nor.o
|
|
obj-$(CONFIG_MTD_MTX1) += mtx-1_flash.o
|
|
obj-$(CONFIG_MTD_INTEL_VR_NOR) += intel_vr_nor.o
|
|
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
|
|
Index: linux-2.6.25.4/drivers/net/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.25.4.orig/drivers/net/Kconfig
|
|
+++ linux-2.6.25.4/drivers/net/Kconfig
|
|
@@ -351,6 +351,12 @@ config MACB
|
|
|
|
source "drivers/net/arm/Kconfig"
|
|
|
|
+config IFXMIPS_MII0
|
|
+ tristate "Infineon IFXMips eth0 driver"
|
|
+ depends on IFXMIPS
|
|
+ help
|
|
+ Support for the MII0 inside the IFXMips SOC
|
|
+
|
|
config AX88796
|
|
tristate "ASIX AX88796 NE2000 clone support"
|
|
depends on ARM || MIPS || SUPERH
|
|
Index: linux-2.6.25.4/drivers/serial/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.25.4.orig/drivers/serial/Kconfig
|
|
+++ linux-2.6.25.4/drivers/serial/Kconfig
|
|
@@ -1327,6 +1327,14 @@ config SERIAL_OF_PLATFORM
|
|
Currently, only 8250 compatible ports are supported, but
|
|
others can easily be added.
|
|
|
|
+config SERIAL_IFXMIPS
|
|
+ bool "IFXMips serial driver"
|
|
+ depends on IFXMIPS
|
|
+ select SERIAL_CORE
|
|
+ select SERIAL_CORE_CONSOLE
|
|
+ help
|
|
+ Driver for the ifxmipss built in ASC hardware
|
|
+
|
|
config SERIAL_QE
|
|
tristate "Freescale QUICC Engine serial port support"
|
|
depends on QUICC_ENGINE
|
|
Index: linux-2.6.25.4/drivers/serial/Makefile
|
|
===================================================================
|
|
--- linux-2.6.25.4.orig/drivers/serial/Makefile
|
|
+++ linux-2.6.25.4/drivers/serial/Makefile
|
|
@@ -66,4 +66,5 @@ obj-$(CONFIG_SERIAL_UARTLITE) += uartlit
|
|
obj-$(CONFIG_SERIAL_NETX) += netx-serial.o
|
|
obj-$(CONFIG_SERIAL_OF_PLATFORM) += of_serial.o
|
|
obj-$(CONFIG_SERIAL_KS8695) += serial_ks8695.o
|
|
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips_asc.o
|
|
obj-$(CONFIG_SERIAL_QE) += ucc_uart.o
|
|
Index: linux-2.6.25.4/drivers/watchdog/Makefile
|
|
===================================================================
|
|
--- linux-2.6.25.4.orig/drivers/watchdog/Makefile
|
|
+++ linux-2.6.25.4/drivers/watchdog/Makefile
|
|
@@ -96,6 +96,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
|
|
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
|
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
|
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
|
+obj-$(CONFIG_IFXMIPS_WDT) += ifxmips_wdt.o
|
|
|
|
# PARISC Architecture
|
|
|