mirror of https://github.com/hak5/openwrt.git
48 lines
917 B
Diff
48 lines
917 B
Diff
--- a/arch/arm/Kconfig
|
|
+++ b/arch/arm/Kconfig
|
|
@@ -1129,10 +1129,15 @@ source "arch/arm/plat-versatile/Kconfig"
|
|
|
|
source "arch/arm/mach-w90x900/Kconfig"
|
|
|
|
+source "arch/arm/plat-fa/Kconfig"
|
|
+
|
|
# Definitions to make life easier
|
|
config ARCH_ACORN
|
|
bool
|
|
|
|
+config PLAT_FA
|
|
+ bool
|
|
+
|
|
config PLAT_IOP
|
|
bool
|
|
select GENERIC_CLOCKEVENTS
|
|
--- a/arch/arm/Makefile
|
|
+++ b/arch/arm/Makefile
|
|
@@ -200,6 +200,7 @@ plat-$(CONFIG_ARCH_MXC) += mxc
|
|
plat-$(CONFIG_ARCH_OMAP) += omap
|
|
plat-$(CONFIG_ARCH_S3C64XX) += samsung
|
|
plat-$(CONFIG_ARCH_ZYNQ) += versatile
|
|
+plat-$(CONFIG_PLAT_FA) += fa
|
|
plat-$(CONFIG_PLAT_IOP) += iop
|
|
plat-$(CONFIG_PLAT_NOMADIK) += nomadik
|
|
plat-$(CONFIG_PLAT_ORION) += orion
|
|
--- /dev/null
|
|
+++ b/arch/arm/plat-fa/Makefile
|
|
@@ -0,0 +1,10 @@
|
|
+#
|
|
+# Makefile for the linux kernel.
|
|
+#
|
|
+
|
|
+obj-y :=
|
|
+
|
|
+obj-m :=
|
|
+obj-n :=
|
|
+obj- :=
|
|
+
|
|
--- /dev/null
|
|
+++ b/arch/arm/plat-fa/Kconfig
|
|
@@ -0,0 +1,3 @@
|
|
+if PLAT_FA
|
|
+
|
|
+endif
|