mirror of https://github.com/hak5/openwrt.git
21 lines
657 B
Diff
21 lines
657 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -135,6 +135,10 @@ config MICREL_PHY
|
|
---help---
|
|
Currently has a driver for the KSZ8041
|
|
|
|
+config MCS814X_PHY
|
|
+ tristate "Driver for the Moschip MCS814x internal PHY"
|
|
+ depends on ARCH_MCS814X
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -38,3 +38,4 @@ obj-$(CONFIG_STE10XP) += ste10Xp.o
|
|
obj-$(CONFIG_MICREL_PHY) += micrel.o
|
|
obj-$(CONFIG_MDIO_OCTEON) += mdio-octeon.o
|
|
obj-$(CONFIG_MICREL_KS8995MA) += spi_ks8995.o
|
|
+obj-$(CONFIG_MCS814X_PHY) += mcs814x.o
|