mirror of https://github.com/hak5/openwrt.git
89 lines
2.7 KiB
Diff
89 lines
2.7 KiB
Diff
--- a/include/asm-generic/vmlinux.lds.h
|
|
+++ b/include/asm-generic/vmlinux.lds.h
|
|
@@ -52,6 +52,16 @@
|
|
#define LOAD_OFFSET 0
|
|
#endif
|
|
|
|
+#ifndef SYMTAB_KEEP
|
|
+#define SYMTAB_KEEP KEEP(*(SORT(___ksymtab+*)))
|
|
+#define SYMTAB_KEEP_GPL KEEP(*(SORT(___ksymtab_gpl+*)))
|
|
+#endif
|
|
+
|
|
+#ifndef SYMTAB_DISCARD
|
|
+#define SYMTAB_DISCARD
|
|
+#define SYMTAB_DISCARD_GPL
|
|
+#endif
|
|
+
|
|
#ifndef SYMBOL_PREFIX
|
|
#define VMLINUX_SYMBOL(sym) sym
|
|
#else
|
|
@@ -304,14 +314,14 @@
|
|
/* Kernel symbol table: Normal symbols */ \
|
|
__ksymtab : AT(ADDR(__ksymtab) - LOAD_OFFSET) { \
|
|
VMLINUX_SYMBOL(__start___ksymtab) = .; \
|
|
- KEEP(*(SORT(___ksymtab+*))) \
|
|
+ SYMTAB_KEEP \
|
|
VMLINUX_SYMBOL(__stop___ksymtab) = .; \
|
|
} \
|
|
\
|
|
/* Kernel symbol table: GPL-only symbols */ \
|
|
__ksymtab_gpl : AT(ADDR(__ksymtab_gpl) - LOAD_OFFSET) { \
|
|
VMLINUX_SYMBOL(__start___ksymtab_gpl) = .; \
|
|
- KEEP(*(SORT(___ksymtab_gpl+*))) \
|
|
+ SYMTAB_KEEP_GPL \
|
|
VMLINUX_SYMBOL(__stop___ksymtab_gpl) = .; \
|
|
} \
|
|
\
|
|
@@ -373,7 +383,7 @@
|
|
\
|
|
/* Kernel symbol table: strings */ \
|
|
__ksymtab_strings : AT(ADDR(__ksymtab_strings) - LOAD_OFFSET) { \
|
|
- *(__ksymtab_strings) \
|
|
+ *(__ksymtab_strings+*) \
|
|
} \
|
|
\
|
|
/* __*init sections */ \
|
|
@@ -710,6 +720,8 @@
|
|
EXIT_TEXT \
|
|
EXIT_DATA \
|
|
EXIT_CALL \
|
|
+ SYMTAB_DISCARD \
|
|
+ SYMTAB_DISCARD_GPL \
|
|
*(.discard) \
|
|
*(.discard.*) \
|
|
}
|
|
--- a/scripts/Makefile.build
|
|
+++ b/scripts/Makefile.build
|
|
@@ -348,7 +348,7 @@ targets += $(extra-y) $(MAKECMDGOALS) $(
|
|
# Linker scripts preprocessor (.lds.S -> .lds)
|
|
# ---------------------------------------------------------------------------
|
|
quiet_cmd_cpp_lds_S = LDS $@
|
|
- cmd_cpp_lds_S = $(CPP) $(cpp_flags) -P -C -U$(ARCH) \
|
|
+ cmd_cpp_lds_S = $(CPP) $(EXTRA_LDSFLAGS) $(cpp_flags) -P -C -U$(ARCH) \
|
|
-D__ASSEMBLY__ -DLINKER_SCRIPT -o $@ $<
|
|
|
|
$(obj)/%.lds: $(src)/%.lds.S FORCE
|
|
--- a/include/linux/export.h
|
|
+++ b/include/linux/export.h
|
|
@@ -45,12 +45,19 @@ extern struct module __this_module;
|
|
#define __CRC_SYMBOL(sym, sec)
|
|
#endif
|
|
|
|
+#ifdef MODULE
|
|
+#define __EXPORT_SUFFIX(sym)
|
|
+#else
|
|
+#define __EXPORT_SUFFIX(sym) "+" #sym
|
|
+#endif
|
|
+
|
|
/* For every exported symbol, place a struct in the __ksymtab section */
|
|
#define __EXPORT_SYMBOL(sym, sec) \
|
|
extern typeof(sym) sym; \
|
|
__CRC_SYMBOL(sym, sec) \
|
|
static const char __kstrtab_##sym[] \
|
|
- __attribute__((section("__ksymtab_strings"), aligned(1))) \
|
|
+ __attribute__((section("__ksymtab_strings" \
|
|
+ __EXPORT_SUFFIX(sym)), aligned(1))) \
|
|
= MODULE_SYMBOL_PREFIX #sym; \
|
|
static const struct kernel_symbol __ksymtab_##sym \
|
|
__used \
|