mirror of https://github.com/hak5/openwrt.git
275 lines
7.6 KiB
Diff
275 lines
7.6 KiB
Diff
--- /dev/null
|
|
+++ b/drivers/net/wireless/rt2x00/rt2x00eeprom.c
|
|
@@ -0,0 +1,98 @@
|
|
+/*
|
|
+ Copyright (C) 2004 - 2009 Ivo van Doorn <IvDoorn@gmail.com>
|
|
+ Copyright (C) 2004 - 2009 Gertjan van Wingerde <gwingerde@gmail.com>
|
|
+ <http://rt2x00.serialmonkey.com>
|
|
+
|
|
+ This program is free software; you can redistribute it and/or modify
|
|
+ it under the terms of the GNU General Public License as published by
|
|
+ the Free Software Foundation; either version 2 of the License, or
|
|
+ (at your option) any later version.
|
|
+
|
|
+ This program is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
|
|
+ GNU General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU General Public License
|
|
+ along with this program; if not, write to the
|
|
+ Free Software Foundation, Inc.,
|
|
+ 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
|
|
+ */
|
|
+
|
|
+/*
|
|
+ Module: rt2x00lib
|
|
+ Abstract: rt2x00 eeprom file loading routines.
|
|
+ */
|
|
+
|
|
+#include <linux/kernel.h>
|
|
+#include <linux/module.h>
|
|
+
|
|
+#include "rt2x00.h"
|
|
+#include "rt2x00lib.h"
|
|
+
|
|
+static int rt2x00lib_request_eeprom_file(struct rt2x00_dev *rt2x00dev)
|
|
+{
|
|
+ const struct firmware *ee;
|
|
+ char *ee_name;
|
|
+ int retval;
|
|
+
|
|
+ ee_name = rt2x00dev->ops->lib->get_eeprom_file_name(rt2x00dev);
|
|
+ if (!ee_name) {
|
|
+ ERROR(rt2x00dev,
|
|
+ "Invalid EEPROM filename.\n"
|
|
+ "Please file bug report to %s.\n", DRV_PROJECT);
|
|
+ return -EINVAL;
|
|
+ }
|
|
+
|
|
+ INFO(rt2x00dev, "Loading EEPROM data from '%s'.\n", ee_name);
|
|
+
|
|
+ retval = request_firmware(&ee, ee_name, rt2x00dev->dev);
|
|
+ if (retval) {
|
|
+ ERROR(rt2x00dev, "Failed to request EEPROM.\n");
|
|
+ return retval;
|
|
+ }
|
|
+
|
|
+ if (!ee || !ee->size || !ee->data) {
|
|
+ ERROR(rt2x00dev, "Failed to read EEPROM file.\n");
|
|
+ retval = -ENOENT;
|
|
+ goto err_exit;
|
|
+ }
|
|
+
|
|
+ if (ee->size != rt2x00dev->ops->eeprom_size) {
|
|
+ ERROR(rt2x00dev,
|
|
+ "EEPROM file size is invalid, it should be %d bytes\n",
|
|
+ rt2x00dev->ops->eeprom_size);
|
|
+ retval = -EINVAL;
|
|
+ goto err_release_ee;
|
|
+ }
|
|
+
|
|
+ rt2x00dev->eeprom_file = ee;
|
|
+ return 0;
|
|
+
|
|
+err_release_ee:
|
|
+ release_firmware(ee);
|
|
+err_exit:
|
|
+ return retval;
|
|
+}
|
|
+
|
|
+int rt2x00lib_load_eeprom_file(struct rt2x00_dev *rt2x00dev)
|
|
+{
|
|
+ int retval;
|
|
+
|
|
+ if (!test_bit(REQUIRE_EEPROM_FILE, &rt2x00dev->cap_flags))
|
|
+ return 0;
|
|
+
|
|
+ if (!rt2x00dev->eeprom_file) {
|
|
+ retval = rt2x00lib_request_eeprom_file(rt2x00dev);
|
|
+ if (retval)
|
|
+ return retval;
|
|
+ }
|
|
+
|
|
+ return 0;
|
|
+}
|
|
+
|
|
+void rt2x00lib_free_eeprom_file(struct rt2x00_dev *rt2x00dev)
|
|
+{
|
|
+ release_firmware(rt2x00dev->eeprom_file);
|
|
+ rt2x00dev->eeprom_file = NULL;
|
|
+}
|
|
--- a/drivers/net/wireless/rt2x00/rt2x00.h
|
|
+++ b/drivers/net/wireless/rt2x00/rt2x00.h
|
|
@@ -561,6 +561,7 @@ struct rt2x00lib_ops {
|
|
const u8 *data, const size_t len);
|
|
int (*load_firmware) (struct rt2x00_dev *rt2x00dev,
|
|
const u8 *data, const size_t len);
|
|
+ char *(*get_eeprom_file_name) (struct rt2x00_dev *rt2x00dev);
|
|
|
|
/*
|
|
* Device initialization/deinitialization handlers.
|
|
@@ -721,6 +722,7 @@ enum rt2x00_capability_flags {
|
|
REQUIRE_SW_SEQNO,
|
|
REQUIRE_HT_TX_DESC,
|
|
REQUIRE_PS_AUTOWAKE,
|
|
+ REQUIRE_EEPROM_FILE,
|
|
|
|
/*
|
|
* Capabilities
|
|
@@ -990,6 +992,11 @@ struct rt2x00_dev {
|
|
const struct firmware *fw;
|
|
|
|
/*
|
|
+ * EEPROM image.
|
|
+ */
|
|
+ const struct firmware *eeprom_file;
|
|
+
|
|
+ /*
|
|
* FIFO for storing tx status reports between isr and tasklet.
|
|
*/
|
|
DECLARE_KFIFO_PTR(txstatus_fifo, u32);
|
|
--- a/drivers/net/wireless/rt2x00/rt2x00lib.h
|
|
+++ b/drivers/net/wireless/rt2x00/rt2x00lib.h
|
|
@@ -322,6 +322,22 @@ static inline void rt2x00lib_free_firmwa
|
|
#endif /* CONFIG_RT2X00_LIB_FIRMWARE */
|
|
|
|
/*
|
|
+ * EEPROM file handlers.
|
|
+ */
|
|
+#ifdef CONFIG_RT2X00_LIB_EEPROM
|
|
+int rt2x00lib_load_eeprom_file(struct rt2x00_dev *rt2x00dev);
|
|
+void rt2x00lib_free_eeprom_file(struct rt2x00_dev *rt2x00dev);
|
|
+#else
|
|
+static inline int rt2x00lib_load_eeprom_file(struct rt2x00_dev *rt2x00dev)
|
|
+{
|
|
+ return 0;
|
|
+}
|
|
+static inline void rt2x00lib_free_eeprom_file(struct rt2x00_dev *rt2x00dev)
|
|
+{
|
|
+}
|
|
+#endif /* CONFIG_RT2X00_LIB_EEPROM_FILE */
|
|
+
|
|
+/*
|
|
* Debugfs handlers.
|
|
*/
|
|
#ifdef CONFIG_RT2X00_LIB_DEBUGFS
|
|
--- a/drivers/net/wireless/rt2x00/Kconfig
|
|
+++ b/drivers/net/wireless/rt2x00/Kconfig
|
|
@@ -60,6 +60,7 @@ config RT2800PCI
|
|
select RT2X00_LIB_PCI if PCI
|
|
select RT2X00_LIB_SOC if RALINK_RT288X || RALINK_RT305X
|
|
select RT2X00_LIB_FIRMWARE
|
|
+ select RT2X00_LIB_EEPROM
|
|
select RT2X00_LIB_CRYPTO
|
|
select CRC_CCITT
|
|
select EEPROM_93CX6
|
|
@@ -212,6 +213,9 @@ config RT2X00_LIB_FIRMWARE
|
|
config RT2X00_LIB_CRYPTO
|
|
boolean
|
|
|
|
+config RT2X00_LIB_EEPROM
|
|
+ boolean
|
|
+
|
|
config RT2X00_LIB_LEDS
|
|
boolean
|
|
default y if (RT2X00_LIB=y && LEDS_CLASS=y) || (RT2X00_LIB=m && LEDS_CLASS!=n)
|
|
--- a/drivers/net/wireless/rt2x00/Makefile
|
|
+++ b/drivers/net/wireless/rt2x00/Makefile
|
|
@@ -7,6 +7,7 @@ rt2x00lib-$(CONFIG_RT2X00_LIB_DEBUGFS) +
|
|
rt2x00lib-$(CONFIG_RT2X00_LIB_CRYPTO) += rt2x00crypto.o
|
|
rt2x00lib-$(CONFIG_RT2X00_LIB_FIRMWARE) += rt2x00firmware.o
|
|
rt2x00lib-$(CONFIG_RT2X00_LIB_LEDS) += rt2x00leds.o
|
|
+rt2x00lib-$(CONFIG_RT2X00_LIB_EEPROM) += rt2x00eeprom.o
|
|
|
|
obj-$(CONFIG_RT2X00_LIB) += rt2x00lib.o
|
|
obj-$(CONFIG_RT2X00_LIB_PCI) += rt2x00pci.o
|
|
--- a/drivers/net/wireless/rt2x00/rt2800pci.c
|
|
+++ b/drivers/net/wireless/rt2x00/rt2800pci.c
|
|
@@ -89,20 +89,10 @@ static void rt2800pci_mcu_status(struct
|
|
rt2x00pci_register_write(rt2x00dev, H2M_MAILBOX_CID, ~0);
|
|
}
|
|
|
|
-#if defined(CONFIG_RALINK_RT288X) || defined(CONFIG_RALINK_RT305X)
|
|
static void rt2800pci_read_eeprom_soc(struct rt2x00_dev *rt2x00dev)
|
|
{
|
|
- void __iomem *base_addr = ioremap(0x1F040000, EEPROM_SIZE);
|
|
-
|
|
- memcpy_fromio(rt2x00dev->eeprom, base_addr, EEPROM_SIZE);
|
|
-
|
|
- iounmap(base_addr);
|
|
+ memcpy(rt2x00dev->eeprom, rt2x00dev->eeprom_file->data, EEPROM_SIZE);
|
|
}
|
|
-#else
|
|
-static inline void rt2800pci_read_eeprom_soc(struct rt2x00_dev *rt2x00dev)
|
|
-{
|
|
-}
|
|
-#endif /* CONFIG_RALINK_RT288X || CONFIG_RALINK_RT305X */
|
|
|
|
#ifdef CONFIG_PCI
|
|
static void rt2800pci_eepromregister_read(struct eeprom_93cx6 *eeprom)
|
|
@@ -322,6 +312,20 @@ static int rt2800pci_write_firmware(stru
|
|
}
|
|
|
|
/*
|
|
+ * EEPROM file functions.
|
|
+ */
|
|
+static char *rt2800pci_get_eeprom_file_name(struct rt2x00_dev *rt2x00dev)
|
|
+{
|
|
+ struct rt2x00_platform_data *pdata;
|
|
+
|
|
+ pdata = rt2x00dev->dev->platform_data;
|
|
+ if (pdata)
|
|
+ return pdata->eeprom_file_name;
|
|
+
|
|
+ return NULL;
|
|
+}
|
|
+
|
|
+/*
|
|
* Initialization functions.
|
|
*/
|
|
static bool rt2800pci_get_entry_state(struct queue_entry *entry)
|
|
@@ -1033,6 +1037,7 @@ static const struct rt2x00lib_ops rt2800
|
|
.get_firmware_name = rt2800pci_get_firmware_name,
|
|
.check_firmware = rt2800_check_firmware,
|
|
.load_firmware = rt2800_load_firmware,
|
|
+ .get_eeprom_file_name = rt2800pci_get_eeprom_file_name,
|
|
.initialize = rt2x00pci_initialize,
|
|
.uninitialize = rt2x00pci_uninitialize,
|
|
.get_entry_state = rt2800pci_get_entry_state,
|
|
--- a/drivers/net/wireless/rt2x00/rt2x00dev.c
|
|
+++ b/drivers/net/wireless/rt2x00/rt2x00dev.c
|
|
@@ -1206,6 +1206,10 @@ int rt2x00lib_probe_dev(struct rt2x00_de
|
|
|
|
rt2x00dev->hw->wiphy->flags |= WIPHY_FLAG_IBSS_RSN;
|
|
|
|
+ retval = rt2x00lib_load_eeprom_file(rt2x00dev);
|
|
+ if (retval)
|
|
+ goto exit;
|
|
+
|
|
/*
|
|
* Initialize work.
|
|
*/
|
|
@@ -1330,6 +1334,11 @@ void rt2x00lib_remove_dev(struct rt2x00_
|
|
*/
|
|
if (rt2x00dev->drv_data)
|
|
kfree(rt2x00dev->drv_data);
|
|
+
|
|
+ /*
|
|
+ * Free EEPROM image.
|
|
+ */
|
|
+ rt2x00lib_free_eeprom_file(rt2x00dev);
|
|
}
|
|
EXPORT_SYMBOL_GPL(rt2x00lib_remove_dev);
|
|
|
|
--- a/drivers/net/wireless/rt2x00/rt2x00soc.c
|
|
+++ b/drivers/net/wireless/rt2x00/rt2x00soc.c
|
|
@@ -94,6 +94,7 @@ int rt2x00soc_probe(struct platform_devi
|
|
rt2x00dev->hw = hw;
|
|
rt2x00dev->irq = platform_get_irq(pdev, 0);
|
|
rt2x00dev->name = pdev->dev.driver->name;
|
|
+ set_bit(REQUIRE_EEPROM_FILE, &rt2x00dev->cap_flags);
|
|
|
|
rt2x00_set_chip_intf(rt2x00dev, RT2X00_CHIP_INTF_SOC);
|
|
|