mirror of https://github.com/hak5/openwrt.git
25 lines
799 B
Diff
25 lines
799 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -88,6 +88,11 @@ config AR8216_PHY
|
|
tristate "Driver for Atheros AR8216 switches"
|
|
select SWCONFIG
|
|
|
|
+config MICREL_PHY
|
|
+ tristate "Drivers for Micrel/Kendin PHYs"
|
|
+ ---help---
|
|
+ Currently has a driver for the KSZ8041
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -18,6 +18,7 @@ obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
obj-$(CONFIG_IP175C_PHY) += ip175c.o
|
|
obj-$(CONFIG_AR8216_PHY) += ar8216.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
+obj-$(CONFIG_MICREL_PHY) += micrel.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|
|
obj-$(CONFIG_MDIO_OF_GPIO) += mdio-ofgpio.o
|