mirror of https://github.com/hak5/openwrt.git
75 lines
2.3 KiB
Diff
75 lines
2.3 KiB
Diff
From 8fd28bca39e31be5a05cb9cf89335a207e8b031f Mon Sep 17 00:00:00 2001
|
|
From: John Crispin <blogic@openwrt.org>
|
|
Date: Fri, 3 Aug 2012 09:53:54 +0200
|
|
Subject: [PATCH 08/25] spi support
|
|
|
|
---
|
|
drivers/spi/Kconfig | 17 +++++++++++++++++
|
|
drivers/spi/Makefile | 3 +++
|
|
2 files changed, 20 insertions(+), 0 deletions(-)
|
|
|
|
diff --git a/drivers/spi/Kconfig b/drivers/spi/Kconfig
|
|
index f62424f..7e8146e 100644
|
|
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -188,6 +188,10 @@ config SPI_MPC52xx
|
|
This drivers supports the MPC52xx SPI controller in master SPI
|
|
mode.
|
|
|
|
+config SPI_FALCON
|
|
+ tristate "Falcon SPI controller support"
|
|
+ depends on SOC_FALCON
|
|
+
|
|
config SPI_MPC52xx_PSC
|
|
tristate "Freescale MPC52xx PSC SPI controller"
|
|
depends on PPC_MPC52xx && EXPERIMENTAL
|
|
@@ -362,6 +366,11 @@ config SPI_TOPCLIFF_PCH
|
|
This driver also supports the ML7213/ML7223/ML7831, a companion chip
|
|
for the Atom E6xx series and compatible with the Intel EG20T PCH.
|
|
|
|
+config SPI_SVIP
|
|
+ tristate "SVIP SPI controller"
|
|
+ depends on SOC_SVIP
|
|
+ default y
|
|
+
|
|
config SPI_TXX9
|
|
tristate "Toshiba TXx9 SPI controller"
|
|
depends on GENERIC_GPIO && CPU_TX49XX
|
|
@@ -387,6 +396,14 @@ config SPI_NUC900
|
|
help
|
|
SPI driver for Nuvoton NUC900 series ARM SoCs
|
|
|
|
+config SPI_XWAY
|
|
+ tristate "Lantiq XWAY SPI controller"
|
|
+ depends on LANTIQ && SOC_TYPE_XWAY
|
|
+ select SPI_BITBANG
|
|
+ help
|
|
+ This driver supports the Lantiq SoC SPI controller in master
|
|
+ mode.
|
|
+
|
|
#
|
|
# Add new SPI master controllers in alphabetical order above this line
|
|
#
|
|
diff --git a/drivers/spi/Makefile b/drivers/spi/Makefile
|
|
index 1514c1d..71e7655 100644
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -25,6 +25,7 @@ obj-$(CONFIG_SPI_DW_MMIO) += spi-dw-mmio.o
|
|
obj-$(CONFIG_SPI_DW_PCI) += spi-dw-midpci.o
|
|
spi-dw-midpci-objs := spi-dw-pci.o spi-dw-mid.o
|
|
obj-$(CONFIG_SPI_EP93XX) += spi-ep93xx.o
|
|
+obj-$(CONFIG_SPI_FALCON) += spi-falcon.o
|
|
obj-$(CONFIG_SPI_FSL_LIB) += spi-fsl-lib.o
|
|
obj-$(CONFIG_SPI_FSL_ESPI) += spi-fsl-espi.o
|
|
obj-$(CONFIG_SPI_FSL_SPI) += spi-fsl-spi.o
|
|
@@ -59,4 +60,6 @@ obj-$(CONFIG_SPI_TLE62X0) += spi-tle62x0.o
|
|
obj-$(CONFIG_SPI_TOPCLIFF_PCH) += spi-topcliff-pch.o
|
|
obj-$(CONFIG_SPI_TXX9) += spi-txx9.o
|
|
obj-$(CONFIG_SPI_XILINX) += spi-xilinx.o
|
|
+obj-$(CONFIG_SPI_XWAY) += spi-xway.o
|
|
+obj-$(CONFIG_SPI_SVIP) += spi_svip.o
|
|
|
|
--
|
|
1.7.9.1
|
|
|