mirror of https://github.com/hak5/openwrt.git
30 lines
904 B
Diff
30 lines
904 B
Diff
--- a/arch/arm/mach-cns3xxx/Makefile
|
|
+++ b/arch/arm/mach-cns3xxx/Makefile
|
|
@@ -1,3 +1,6 @@
|
|
obj-$(CONFIG_ARCH_CNS3XXX) += core.o pm.o devices.o
|
|
obj-$(CONFIG_PCI) += pcie.o
|
|
obj-$(CONFIG_MACH_CNS3420VB) += cns3420vb.o
|
|
+obj-$(CONFIG_SMP) += platsmp.o headsmp.o
|
|
+obj-$(CONFIG_HOTPLUG_CPU) += hotplug.o
|
|
+obj-$(CONFIG_LOCAL_TIMERS) += localtimer.o
|
|
--- a/arch/arm/mach-cns3xxx/Kconfig
|
|
+++ b/arch/arm/mach-cns3xxx/Kconfig
|
|
@@ -3,6 +3,7 @@ menu "CNS3XXX platform type"
|
|
|
|
config MACH_CNS3420VB
|
|
bool "Support for CNS3420 Validation Board"
|
|
+ select HAVE_ARM_SCU if SMP
|
|
select MIGHT_HAVE_PCI
|
|
help
|
|
Include support for the Cavium Networks CNS3420 MPCore Platform
|
|
--- a/arch/arm/Kconfig
|
|
+++ b/arch/arm/Kconfig
|
|
@@ -373,6 +373,7 @@ config ARCH_CNS3XXX
|
|
select MIGHT_HAVE_PCI
|
|
select PCI_DOMAINS if PCI
|
|
select HAVE_ARM_TWD
|
|
+ select HAVE_SMP
|
|
help
|
|
Support for Cavium Networks CNS3XXX platform.
|
|
|