mirror of https://github.com/hak5/openwrt.git
41 lines
1.7 KiB
Diff
41 lines
1.7 KiB
Diff
diff -ruN linux-2.6.26.3.orig/drivers/mtd/Kconfig linux-2.6.26.3/drivers/mtd/Kconfig
|
|
--- linux-2.6.26.3.orig/drivers/mtd/Kconfig 2008-08-27 19:37:48.000000000 -0700
|
|
+++ linux-2.6.26.3/drivers/mtd/Kconfig 2008-08-27 19:39:14.000000000 -0700
|
|
@@ -174,6 +174,12 @@
|
|
---help---
|
|
TI AR7 partitioning support
|
|
|
|
+config MTD_AR7_PARTS
|
|
+ tristate "TI AR7 partitioning support"
|
|
+ depends on MTD_PARTITIONS
|
|
+ ---help---
|
|
+ TI AR7 partitioning support
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
config MTD_CHAR
|
|
diff -ruN linux-2.6.26.3.orig/drivers/mtd/Makefile linux-2.6.26.3/drivers/mtd/Makefile
|
|
--- linux-2.6.26.3.orig/drivers/mtd/Makefile 2008-08-27 19:37:48.000000000 -0700
|
|
+++ linux-2.6.26.3/drivers/mtd/Makefile 2008-08-27 19:39:14.000000000 -0700
|
|
@@ -13,6 +13,7 @@
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
+obj-$(CONFIG_MTD_AR7_PARTS) += ar7part.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
|
|
diff -ruN linux-2.6.26.3.orig/drivers/mtd/maps/physmap.c linux-2.6.26.3/drivers/mtd/maps/physmap.c
|
|
--- linux-2.6.26.3.orig/drivers/mtd/maps/physmap.c 2008-08-27 19:37:48.000000000 -0700
|
|
+++ linux-2.6.26.3/drivers/mtd/maps/physmap.c 2008-08-27 19:39:14.000000000 -0700
|
|
@@ -87,7 +87,8 @@
|
|
|
|
static const char *rom_probe_types[] = { "cfi_probe", "jedec_probe", "map_rom", NULL };
|
|
#ifdef CONFIG_MTD_PARTITIONS
|
|
-static const char *part_probe_types[] = { "cmdlinepart", "RedBoot", NULL };
|
|
+static const char *part_probe_types[] = {"cmdlinepart", "RedBoot",
|
|
+ "ar7part", NULL };
|
|
#endif
|
|
|
|
static int physmap_flash_probe(struct platform_device *dev)
|