mirror of https://github.com/hak5/openwrt.git
48 lines
913 B
Diff
48 lines
913 B
Diff
--- a/arch/arm/Kconfig
|
|
+++ b/arch/arm/Kconfig
|
|
@@ -1028,10 +1028,15 @@ source "arch/arm/mach-w90x900/Kconfig"
|
|
|
|
source "arch/arm/mach-zynq/Kconfig"
|
|
|
|
+source "arch/arm/plat-fa/Kconfig"
|
|
+
|
|
# Definitions to make life easier
|
|
config ARCH_ACORN
|
|
bool
|
|
|
|
+config PLAT_FA
|
|
+ bool
|
|
+
|
|
config PLAT_IOP
|
|
bool
|
|
select GENERIC_CLOCKEVENTS
|
|
--- a/arch/arm/Makefile
|
|
+++ b/arch/arm/Makefile
|
|
@@ -205,6 +205,7 @@ machine-$(CONFIG_ARCH_SUNXI) += sunxi
|
|
plat-$(CONFIG_ARCH_OMAP) += omap
|
|
plat-$(CONFIG_ARCH_S3C64XX) += samsung
|
|
plat-$(CONFIG_PLAT_IOP) += iop
|
|
+plat-$(CONFIG_PLAT_FA) += fa
|
|
plat-$(CONFIG_PLAT_ORION) += orion
|
|
plat-$(CONFIG_PLAT_PXA) += pxa
|
|
plat-$(CONFIG_PLAT_S3C24XX) += samsung
|
|
--- /dev/null
|
|
+++ b/arch/arm/plat-fa/Makefile
|
|
@@ -0,0 +1,10 @@
|
|
+#
|
|
+# Makefile for the linux kernel.
|
|
+#
|
|
+
|
|
+obj-y :=
|
|
+
|
|
+obj-m :=
|
|
+obj-n :=
|
|
+obj- :=
|
|
+
|
|
--- /dev/null
|
|
+++ b/arch/arm/plat-fa/Kconfig
|
|
@@ -0,0 +1,3 @@
|
|
+if PLAT_FA
|
|
+
|
|
+endif
|