mirror of https://github.com/hak5/openwrt.git
25 lines
717 B
Diff
25 lines
717 B
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -55,6 +55,11 @@ config MTD_ROOTFS_SPLIT
|
|
depends on MTD_PARTITIONS
|
|
default y
|
|
|
|
+config MTD_TRXSPLIT
|
|
+ bool "Automatically find and split TRX partitions"
|
|
+ depends on MTD_PARTITIONS
|
|
+ default n
|
|
+
|
|
config MTD_REDBOOT_PARTS
|
|
tristate "RedBoot partition table parsing"
|
|
depends on MTD_PARTITIONS
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -8,6 +8,7 @@ mtd-y := mtdcore.o mtdsuper.o
|
|
mtd-$(CONFIG_MTD_PARTITIONS) += mtdpart.o
|
|
|
|
obj-$(CONFIG_MTD_CONCAT) += mtdconcat.o
|
|
+obj-$(CONFIG_MTD_TRXSPLIT) += trxsplit.o
|
|
obj-$(CONFIG_MTD_REDBOOT_PARTS) += redboot.o
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|