mirror of https://github.com/hak5/openwrt.git
44 lines
1.8 KiB
Diff
44 lines
1.8 KiB
Diff
diff -ur linux-2.6.22.4.old/arch/mips/kernel/time.c linux-2.6.22.4.new/arch/mips/kernel/time.c
|
|
--- linux-2.6.22.4.old/arch/mips/kernel/time.c 2007-08-21 06:33:06.000000000 +0200
|
|
+++ linux-2.6.22.4.new/arch/mips/kernel/time.c 2007-12-24 17:13:43.000000000 +0100
|
|
@@ -478,3 +478,5 @@
|
|
EXPORT_SYMBOL(to_tm);
|
|
EXPORT_SYMBOL(rtc_mips_set_time);
|
|
EXPORT_SYMBOL(rtc_mips_get_time);
|
|
+EXPORT_SYMBOL(mips_hpt_frequency);
|
|
+
|
|
diff -ur linux-2.6.22.4.old/drivers/char/watchdog/Kconfig linux-2.6.22.4.new/drivers/char/watchdog/Kconfig
|
|
--- linux-2.6.22.4.old/drivers/char/watchdog/Kconfig 2007-08-21 06:33:06.000000000 +0200
|
|
+++ linux-2.6.22.4.new/drivers/char/watchdog/Kconfig 2007-12-24 17:13:43.000000000 +0100
|
|
@@ -575,6 +575,19 @@
|
|
To compile this driver as a module, choose M here: the
|
|
module will be called rm9k_wdt.
|
|
|
|
+config RC32434_WDT
|
|
+ tristate "IDT Interprise 79RC32434 SoC hardware watchdog"
|
|
+ depends on WATCHDOG && MIKROTIK_RB500
|
|
+ help
|
|
+ This is a driver for hardware watchdog integrated in IDT Interprise
|
|
+ 79RC32434 SoC. This watchdog simply watches your kernel to make sure
|
|
+ it doesn't freeze, and if it does, it reboots your computer after a
|
|
+ certain amount of time.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the module will be
|
|
+ called rc32434_wdt.
|
|
+
|
|
+
|
|
# S390 Architecture
|
|
|
|
config ZVM_WATCHDOG
|
|
diff -ur linux-2.6.22.4.old/drivers/char/watchdog/Makefile linux-2.6.22.4.new/drivers/char/watchdog/Makefile
|
|
--- linux-2.6.22.4.old/drivers/char/watchdog/Makefile 2007-08-21 06:33:06.000000000 +0200
|
|
+++ linux-2.6.22.4.new/drivers/char/watchdog/Makefile 2007-12-24 17:13:43.000000000 +0100
|
|
@@ -75,6 +75,7 @@
|
|
obj-$(CONFIG_INDYDOG) += indydog.o
|
|
obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
|
|
obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
|
|
+obj-$(CONFIG_RC32434_WDT) += rc32434_wdt.o
|
|
|
|
# S390 Architecture
|
|
|