mirror of https://github.com/hak5/openwrt.git
27 lines
832 B
Diff
27 lines
832 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -217,6 +217,13 @@ config SPI_XILINX
|
|
See the "OPB Serial Peripheral Interface (SPI) (v1.00e)"
|
|
Product Specification document (DS464) for hardware details.
|
|
|
|
+config SPI_BCM63XX
|
|
+ tristate "Broadcom BCM63xx SPI controller"
|
|
+ depends on BCM63XX
|
|
+ select SPI_BITBANG
|
|
+ help
|
|
+ SPI driver for the Broadcom BCM63xx SPI controller.
|
|
+
|
|
#
|
|
# Add new SPI master controllers in alphabetical order above this line
|
|
#
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -30,6 +30,7 @@ obj-$(CONFIG_SPI_S3C24XX) += spi_s3c24x
|
|
obj-$(CONFIG_SPI_TXX9) += spi_txx9.o
|
|
obj-$(CONFIG_SPI_XILINX) += xilinx_spi.o
|
|
obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.o
|
|
+obj-$(CONFIG_SPI_BCM63XX) += bcm63xx_spi.o
|
|
# ... add above this line ...
|
|
|
|
# SPI protocol drivers (device/link on bus)
|