mirror of https://github.com/hak5/openwrt.git
40 lines
1.4 KiB
Diff
40 lines
1.4 KiB
Diff
--- a/arch/mips/ath79/Kconfig
|
|
+++ b/arch/mips/ath79/Kconfig
|
|
@@ -374,6 +374,16 @@ config ATH79_MACH_OM2P
|
|
select ATH79_DEV_M25P80
|
|
select ATH79_DEV_WMAC
|
|
|
|
+config ATH79_MACH_MR600
|
|
+ bool "OpenMesh MR600 board support"
|
|
+ select SOC_AR934X
|
|
+ select ATH79_DEV_AP9X_PCI if PCI
|
|
+ select ATH79_DEV_ETH
|
|
+ select ATH79_DEV_GPIO_BUTTONS
|
|
+ select ATH79_DEV_LEDS_GPIO
|
|
+ select ATH79_DEV_M25P80
|
|
+ select ATH79_DEV_WMAC
|
|
+
|
|
config ATH79_MACH_MZK_W04NU
|
|
bool "Planex MZK-W04NU board support"
|
|
select SOC_AR913X
|
|
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
@@ -43,6 +43,7 @@ enum ath79_mach_type {
|
|
ATH79_MACH_JA76PF2, /* jjPlus JA76PF2 */
|
|
ATH79_MACH_JWAP003, /* jjPlus JWAP003 */
|
|
ATH79_MACH_HORNET_UB, /* ALFA Networks Hornet-UB */
|
|
+ ATH79_MACH_MR600, /* OpenMesh MR600 */
|
|
ATH79_MACH_MZK_W04NU, /* Planex MZK-W04NU */
|
|
ATH79_MACH_MZK_W300NH, /* Planex MZK-W300NH */
|
|
ATH79_MACH_NBG460N, /* Zyxel NBG460N/550N/550NH */
|
|
--- a/arch/mips/ath79/Makefile
|
|
+++ b/arch/mips/ath79/Makefile
|
|
@@ -59,6 +59,7 @@ obj-$(CONFIG_ATH79_MACH_EAP7660D) += mac
|
|
obj-$(CONFIG_ATH79_MACH_JA76PF) += mach-ja76pf.o
|
|
obj-$(CONFIG_ATH79_MACH_JWAP003) += mach-jwap003.o
|
|
obj-$(CONFIG_ATH79_MACH_HORNET_UB) += mach-hornet-ub.o
|
|
+obj-$(CONFIG_ATH79_MACH_MR600) += mach-mr600.o
|
|
obj-$(CONFIG_ATH79_MACH_MZK_W04NU) += mach-mzk-w04nu.o
|
|
obj-$(CONFIG_ATH79_MACH_MZK_W300NH) += mach-mzk-w300nh.o
|
|
obj-$(CONFIG_ATH79_MACH_NBG460N) += mach-nbg460n.o
|