mirror of https://github.com/hak5/openwrt.git
88 lines
2.4 KiB
Diff
88 lines
2.4 KiB
Diff
From e3abd028e7631ee952fe73d8f9ee97bc615526a8 Mon Sep 17 00:00:00 2001
|
|
From: Axel Gembe <ago@bastart.eu.org>
|
|
Date: Sat, 17 May 2008 16:07:46 +0200
|
|
Subject: [PATCH] bcm963xx: remove unused int-handler.S
|
|
|
|
The code is not used anymore.
|
|
|
|
Signed-off-by: Axel Gembe <ago@bastart.eu.org>
|
|
---
|
|
arch/mips/bcm963xx/Makefile | 2 +-
|
|
arch/mips/bcm963xx/int-handler.S | 59 --------------------------------------
|
|
2 files changed, 1 insertions(+), 60 deletions(-)
|
|
delete mode 100644 arch/mips/bcm963xx/int-handler.S
|
|
|
|
--- a/arch/mips/bcm963xx/Makefile
|
|
+++ b/arch/mips/bcm963xx/Makefile
|
|
@@ -3,7 +3,7 @@
|
|
#
|
|
# Copyright (C) 2004 Broadcom Corporation
|
|
#
|
|
-obj-y := irq.o prom.o setup.o time.o ser_init.o int-handler.o info.o wdt.o
|
|
+obj-y := irq.o prom.o setup.o time.o ser_init.o info.o wdt.o
|
|
|
|
SRCBASE := $(TOPDIR)
|
|
EXTRA_CFLAGS += -I$(SRCBASE)/include
|
|
--- a/arch/mips/bcm963xx/int-handler.S
|
|
+++ /dev/null
|
|
@@ -1,59 +0,0 @@
|
|
-/*
|
|
-<:copyright-gpl
|
|
- Copyright 2002 Broadcom Corp. All Rights Reserved.
|
|
-
|
|
- This program is free software; you can distribute it and/or modify it
|
|
- under the terms of the GNU General Public License (Version 2) as
|
|
- published by the Free Software Foundation.
|
|
-
|
|
- This program is distributed in the hope it will be useful, but WITHOUT
|
|
- ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
|
|
- FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
|
|
- for more details.
|
|
-
|
|
- You should have received a copy of the GNU General Public License along
|
|
- with this program; if not, write to the Free Software Foundation, Inc.,
|
|
- 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
|
|
-:>
|
|
-*/
|
|
-/*
|
|
- * Generic interrupt handler for Broadcom MIPS boards
|
|
- */
|
|
-
|
|
-#include <linux/autoconf.h>
|
|
-
|
|
-#include <asm/asm.h>
|
|
-#include <asm/mipsregs.h>
|
|
-#include <asm/regdef.h>
|
|
-#include <asm/stackframe.h>
|
|
-
|
|
-/*
|
|
- * MIPS IRQ Source
|
|
- * -------- ------
|
|
- * 0 Software (ignored)
|
|
- * 1 Software (ignored)
|
|
- * 2 Combined hardware interrupt (hw0)
|
|
- * 3 Hardware
|
|
- * 4 Hardware
|
|
- * 5 Hardware
|
|
- * 6 Hardware
|
|
- * 7 R4k timer
|
|
- */
|
|
-
|
|
- .text
|
|
- .set noreorder
|
|
- .set noat
|
|
- .align 5
|
|
- NESTED(brcmIRQ, PT_SIZE, sp)
|
|
- SAVE_ALL
|
|
- CLI
|
|
- .set noreorder
|
|
- .set at
|
|
-
|
|
- jal plat_irq_dispatch
|
|
- move a0, sp
|
|
-
|
|
- j ret_from_irq
|
|
- nop
|
|
-
|
|
- END(brcmIRQ)
|