mirror of https://github.com/hak5/openwrt.git
28 lines
893 B
Diff
28 lines
893 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -68,6 +68,14 @@ config SPI_AR71XX
|
|
help
|
|
This is the SPI contoller driver for Atheros AR71xx.
|
|
|
|
+config SPI_PB44
|
|
+ tristate "Atheros PB44 board specific SPI controller"
|
|
+ depends on SPI_MASTER && AR71XX_MACH_PB44
|
|
+ select SPI_BITBANG
|
|
+ help
|
|
+ This is a specific SPI controller driver for the Atheros PB44
|
|
+ reference board.
|
|
+
|
|
config SPI_ATMEL
|
|
tristate "Atmel SPI Controller"
|
|
depends on (ARCH_AT91 || AVR32)
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -28,6 +28,7 @@ obj-$(CONFIG_SPI_GPIO) += spi_gpio.o
|
|
obj-$(CONFIG_SPI_GPIO_OLD) += spi_gpio_old.o
|
|
obj-$(CONFIG_SPI_IMX) += spi_imx.o
|
|
obj-$(CONFIG_SPI_LM70_LLP) += spi_lm70llp.o
|
|
+obj-$(CONFIG_SPI_PB44) += pb44_spi.o
|
|
obj-$(CONFIG_SPI_PXA2XX) += pxa2xx_spi.o
|
|
obj-$(CONFIG_SPI_OMAP_UWIRE) += omap_uwire.o
|
|
obj-$(CONFIG_SPI_OMAP24XX) += omap2_mcspi.o
|