mirror of https://github.com/hak5/openwrt.git
32 lines
1.1 KiB
Diff
32 lines
1.1 KiB
Diff
--- a/drivers/watchdog/Kconfig
|
|
+++ b/drivers/watchdog/Kconfig
|
|
@@ -848,6 +848,18 @@ config RC32434_WDT
|
|
To compile this driver as a module, choose M here: the
|
|
module will be called rc32434_wdt.
|
|
|
|
+config ADM5120_WDT
|
|
+ tristate "Infineon ADM5120 SoC hardware watchdog"
|
|
+ depends on WATCHDOG && ADM5120
|
|
+ help
|
|
+ This is a driver for hardware watchdog integrated in Infineon
|
|
+ ADM5120 SoC. This watchdog simply watches your kernel to make sure
|
|
+ it doesn't freeze, and if it does, it reboots your computer after a
|
|
+ certain amount of time.
|
|
+
|
|
+ To compile this driver as a module, choose M here: the module will be
|
|
+ called adm5120_wdt.
|
|
+
|
|
config INDYDOG
|
|
tristate "Indy/I2 Hardware Watchdog"
|
|
depends on SGI_HAS_INDYDOG
|
|
--- a/drivers/watchdog/Makefile
|
|
+++ b/drivers/watchdog/Makefile
|
|
@@ -110,6 +110,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
|
|
# MIPS Architecture
|
|
obj-$(CONFIG_BCM47XX_WDT) += bcm47xx_wdt.o
|
|
obj-$(CONFIG_RC32434_WDT) += rc32434_wdt.o
|
|
+obj-$(CONFIG_ADM5120_WDT) += adm5120_wdt.o
|
|
obj-$(CONFIG_INDYDOG) += indydog.o
|
|
obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
|
|
obj-$(CONFIG_PNX833X_WDT) += pnx833x_wdt.o
|