mirror of https://github.com/hak5/openwrt.git
23 lines
784 B
Diff
23 lines
784 B
Diff
--- a/arch/mips/pci/Makefile
|
|
+++ b/arch/mips/pci/Makefile
|
|
@@ -18,6 +18,7 @@ obj-$(CONFIG_PCI_TX4927) += ops-tx4927.o
|
|
obj-$(CONFIG_BCM47XX) += pci-bcm47xx.o
|
|
obj-$(CONFIG_BCM63XX) += pci-bcm63xx.o fixup-bcm63xx.o \
|
|
ops-bcm63xx.o
|
|
+obj-$(CONFIG_ADM5120) += pci-adm5120.o
|
|
obj-$(CONFIG_MIPS_ALCHEMY) += pci-alchemy.o
|
|
obj-$(CONFIG_SOC_AR71XX) += pci-ar71xx.o
|
|
obj-$(CONFIG_PCI_AR724X) += pci-ar724x.o
|
|
--- a/include/linux/pci_ids.h
|
|
+++ b/include/linux/pci_ids.h
|
|
@@ -1807,6 +1807,9 @@
|
|
#define PCI_VENDOR_ID_ESDGMBH 0x12fe
|
|
#define PCI_DEVICE_ID_ESDGMBH_CPCIASIO4 0x0111
|
|
|
|
+#define PCI_VENDOR_ID_ADMTEK 0x1317
|
|
+#define PCI_DEVICE_ID_ADMTEK_ADM5120 0x5120
|
|
+
|
|
#define PCI_VENDOR_ID_SIIG 0x131f
|
|
#define PCI_SUBVENDOR_ID_SIIG 0x131f
|
|
#define PCI_DEVICE_ID_SIIG_1S_10x_550 0x1000
|