mirror of https://github.com/hak5/openwrt.git
26 lines
881 B
Diff
26 lines
881 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -290,6 +290,12 @@ config SPI_PXA2XX
|
|
The driver can be configured to use any SSP port and additional
|
|
documentation can be found a Documentation/spi/pxa2xx.
|
|
|
|
+config SPI_RB4XX
|
|
+ tristate "Mikrotik RB4XX SPI master"
|
|
+ depends on SPI_MASTER && AR71XX_MACH_RB4XX
|
|
+ help
|
|
+ SPI controller driver for the Mikrotik RB4xx series boards.
|
|
+
|
|
config SPI_S3C24XX
|
|
tristate "Samsung S3C24XX series SPI"
|
|
depends on ARCH_S3C2410 && EXPERIMENTAL
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -51,6 +51,7 @@ obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.
|
|
obj-$(CONFIG_SPI_SH_MSIOF) += spi_sh_msiof.o
|
|
obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
|
|
obj-$(CONFIG_SPI_NUC900) += spi_nuc900.o
|
|
+obj-$(CONFIG_SPI_RB4XX) += rb4xx_spi.o
|
|
|
|
# special build for s3c24xx spi driver with fiq support
|
|
spi_s3c24xx_hw-y := spi_s3c24xx.o
|