mirror of https://github.com/hak5/openwrt.git
30 lines
1.1 KiB
Diff
30 lines
1.1 KiB
Diff
Index: linux-2.6.24.7/drivers/net/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.24.7.orig/drivers/net/Kconfig
|
|
+++ linux-2.6.24.7/drivers/net/Kconfig
|
|
@@ -362,6 +362,12 @@ config AX88796_93CX6
|
|
help
|
|
Select this if your platform comes with an external 93CX6 eeprom.
|
|
|
|
+config AR2313
|
|
+ tristate "AR2313 Ethernet support"
|
|
+ depends on NET_ETHERNET && ATHEROS
|
|
+ help
|
|
+ Support for the AR231x/531x ethernet controller
|
|
+
|
|
config MACE
|
|
tristate "MACE (Power Mac ethernet) support"
|
|
depends on PPC_PMAC && PPC32
|
|
Index: linux-2.6.24.7/drivers/net/Makefile
|
|
===================================================================
|
|
--- linux-2.6.24.7.orig/drivers/net/Makefile
|
|
+++ linux-2.6.24.7/drivers/net/Makefile
|
|
@@ -190,6 +190,7 @@ obj-$(CONFIG_MVME147_NET) += mvme147.o 7
|
|
obj-$(CONFIG_EQUALIZER) += eql.o
|
|
obj-$(CONFIG_MIPS_JAZZ_SONIC) += jazzsonic.o
|
|
obj-$(CONFIG_MIPS_AU1X00_ENET) += au1000_eth.o
|
|
+obj-$(CONFIG_AR2313) += ar2313/
|
|
obj-$(CONFIG_MIPS_SIM_NET) += mipsnet.o
|
|
obj-$(CONFIG_SGI_IOC3_ETH) += ioc3-eth.o
|
|
obj-$(CONFIG_DECLANCE) += declance.o
|