mirror of https://github.com/hak5/openwrt.git
26 lines
867 B
Diff
26 lines
867 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -309,6 +309,12 @@ config SPI_RSPI
|
|
help
|
|
SPI driver for Renesas RSPI blocks.
|
|
|
|
+config SPI_RAMIPS
|
|
+ tristate "Ralink RT288x/RT305x/RT3662 SPI Controller"
|
|
+ depends on (SOC_RT288X || SOC_RT305X || SOC_RT3883)
|
|
+ help
|
|
+ This selects a driver for the Ralink RT288x/RT305x SPI Controller.
|
|
+
|
|
config SPI_S3C24XX
|
|
tristate "Samsung S3C24XX series SPI"
|
|
depends on ARCH_S3C24XX && EXPERIMENTAL
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -47,6 +47,7 @@ obj-$(CONFIG_SPI_PL022) += spi-pl022.o
|
|
obj-$(CONFIG_SPI_PPC4xx) += spi-ppc4xx.o
|
|
obj-$(CONFIG_SPI_PXA2XX) += spi-pxa2xx.o
|
|
obj-$(CONFIG_SPI_PXA2XX_PCI) += spi-pxa2xx-pci.o
|
|
+obj-$(CONFIG_SPI_RAMIPS) += spi-ramips.o
|
|
obj-$(CONFIG_SPI_RSPI) += spi-rspi.o
|
|
obj-$(CONFIG_SPI_S3C24XX) += spi-s3c24xx-hw.o
|
|
spi-s3c24xx-hw-y := spi-s3c24xx.o
|