mirror of https://github.com/hak5/openwrt.git
142 lines
5.3 KiB
Diff
142 lines
5.3 KiB
Diff
Index: linux-2.6.35.8/drivers/serial/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/serial/Kconfig 2010-10-29 06:52:43.000000000 +0200
|
|
+++ linux-2.6.35.8/drivers/serial/Kconfig 2010-11-01 11:34:31.000000000 +0100
|
|
@@ -1397,6 +1397,14 @@
|
|
help
|
|
Support for Console on the NWP serial ports.
|
|
|
|
+config SERIAL_IFXMIPS
|
|
+ bool "IFXMips serial driver"
|
|
+ depends on IFXMIPS
|
|
+ select SERIAL_CORE
|
|
+ select SERIAL_CORE_CONSOLE
|
|
+ help
|
|
+ Driver for the ifxmipss built in ASC hardware
|
|
+
|
|
config SERIAL_QE
|
|
tristate "Freescale QUICC Engine serial port support"
|
|
depends on QUICC_ENGINE
|
|
Index: linux-2.6.35.8/drivers/serial/Makefile
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/serial/Makefile 2010-10-29 06:52:43.000000000 +0200
|
|
+++ linux-2.6.35.8/drivers/serial/Makefile 2010-11-01 11:34:55.000000000 +0100
|
|
@@ -84,3 +84,4 @@
|
|
obj-$(CONFIG_SERIAL_GRLIB_GAISLER_APBUART) += apbuart.o
|
|
obj-$(CONFIG_SERIAL_ALTERA_JTAGUART) += altera_jtaguart.o
|
|
obj-$(CONFIG_SERIAL_ALTERA_UART) += altera_uart.o
|
|
+obj-$(CONFIG_SERIAL_IFXMIPS) += ifxmips.o
|
|
Index: linux-2.6.35.8/drivers/net/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/net/Kconfig 2010-10-29 06:52:43.000000000 +0200
|
|
+++ linux-2.6.35.8/drivers/net/Kconfig 2010-11-01 11:34:31.000000000 +0100
|
|
@@ -232,6 +232,12 @@
|
|
|
|
source "drivers/net/arm/Kconfig"
|
|
|
|
+config IFXMIPS_MII0
|
|
+ tristate "Infineon IFXMips eth0 driver"
|
|
+ depends on IFXMIPS
|
|
+ help
|
|
+ Support for the MII0 inside the IFXMips SOC
|
|
+
|
|
config AX88796
|
|
tristate "ASIX AX88796 NE2000 clone support"
|
|
depends on ARM || MIPS || SUPERH
|
|
Index: linux-2.6.35.8/drivers/net/Makefile
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/net/Makefile 2010-10-29 06:52:43.000000000 +0200
|
|
+++ linux-2.6.35.8/drivers/net/Makefile 2010-11-01 11:35:13.000000000 +0100
|
|
@@ -252,6 +252,7 @@
|
|
obj-$(CONFIG_ENC28J60) += enc28j60.o
|
|
obj-$(CONFIG_ETHOC) += ethoc.o
|
|
obj-$(CONFIG_GRETH) += greth.o
|
|
+obj-$(CONFIG_IFXMIPS_MII0) += ifxmips.o
|
|
|
|
obj-$(CONFIG_XTENSA_XT2000_SONIC) += xtsonic.o
|
|
|
|
Index: linux-2.6.35.8/drivers/mtd/maps/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/mtd/maps/Kconfig 2010-10-29 06:52:43.000000000 +0200
|
|
+++ linux-2.6.35.8/drivers/mtd/maps/Kconfig 2010-11-01 11:34:31.000000000 +0100
|
|
@@ -251,6 +251,12 @@
|
|
help
|
|
Support for flash chips on NETtel/SecureEdge/SnapGear boards.
|
|
|
|
+config MTD_IFXMIPS
|
|
+ tristate "IFXMIPS MTD support"
|
|
+ depends on IFXMIPS
|
|
+ help
|
|
+ Flash memory access on AMD Alchemy Pb/Db/RDK Reference Boards
|
|
+
|
|
config MTD_DILNETPC
|
|
tristate "CFI Flash device mapped on DIL/Net PC"
|
|
depends on X86 && MTD_CONCAT && MTD_PARTITIONS && MTD_CFI_INTELEXT && BROKEN
|
|
Index: linux-2.6.35.8/drivers/mtd/maps/Makefile
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/mtd/maps/Makefile 2010-10-29 06:52:43.000000000 +0200
|
|
+++ linux-2.6.35.8/drivers/mtd/maps/Makefile 2010-11-01 11:34:31.000000000 +0100
|
|
@@ -59,3 +59,4 @@
|
|
obj-$(CONFIG_MTD_RBTX4939) += rbtx4939-flash.o
|
|
obj-$(CONFIG_MTD_VMU) += vmu-flash.o
|
|
obj-$(CONFIG_MTD_GPIO_ADDR) += gpio-addr-flash.o
|
|
+obj-$(CONFIG_MTD_IFXMIPS) += ifxmips.o
|
|
Index: linux-2.6.35.8/drivers/watchdog/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/watchdog/Kconfig 2010-10-29 06:52:43.000000000 +0200
|
|
+++ linux-2.6.35.8/drivers/watchdog/Kconfig 2010-11-01 11:34:31.000000000 +0100
|
|
@@ -875,6 +875,12 @@
|
|
help
|
|
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
|
|
|
|
+config IFXMIPS_WDT
|
|
+ bool "IFXMips watchdog"
|
|
+ depends on IFXMIPS
|
|
+ help
|
|
+ Hardware driver for the IFXMIPS Watchdog Timer.
|
|
+
|
|
# PARISC Architecture
|
|
|
|
# POWERPC Architecture
|
|
Index: linux-2.6.35.8/drivers/watchdog/Makefile
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/watchdog/Makefile 2010-10-29 06:52:43.000000000 +0200
|
|
+++ linux-2.6.35.8/drivers/watchdog/Makefile 2010-11-01 11:34:31.000000000 +0100
|
|
@@ -114,6 +114,7 @@
|
|
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
|
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
|
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
|
+obj-$(CONFIG_IFXMIPS_WDT) += ifxmips.o
|
|
|
|
# PARISC Architecture
|
|
|
|
Index: linux-2.6.35.8/drivers/leds/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/leds/Kconfig 2010-11-01 11:19:33.000000000 +0100
|
|
+++ linux-2.6.35.8/drivers/leds/Kconfig 2010-11-01 11:34:31.000000000 +0100
|
|
@@ -311,6 +311,12 @@
|
|
|
|
if LEDS_TRIGGERS
|
|
|
|
+config LEDS_IFXMIPS
|
|
+ tristate "LED Support for IFXMIPS LEDs"
|
|
+ depends on LEDS_CLASS && IFXMIPS
|
|
+ help
|
|
+ This option enables support for the CM-X270 LEDs.
|
|
+
|
|
comment "LED Triggers"
|
|
|
|
config LEDS_TRIGGER_TIMER
|
|
Index: linux-2.6.35.8/drivers/leds/Makefile
|
|
===================================================================
|
|
--- linux-2.6.35.8.orig/drivers/leds/Makefile 2010-11-01 11:19:33.000000000 +0100
|
|
+++ linux-2.6.35.8/drivers/leds/Makefile 2010-11-01 11:35:43.000000000 +0100
|
|
@@ -37,6 +37,7 @@
|
|
obj-$(CONFIG_LEDS_ADP5520) += leds-adp5520.o
|
|
obj-$(CONFIG_LEDS_DELL_NETBOOKS) += dell-led.o
|
|
obj-$(CONFIG_LEDS_MC13783) += leds-mc13783.o
|
|
+obj-$(CONFIG_LEDS_IFXMIPS) += leds-ifxmips.o
|
|
|
|
# LED SPI Drivers
|
|
obj-$(CONFIG_LEDS_DAC124S085) += leds-dac124s085.o
|