mirror of https://github.com/hak5/openwrt.git
39 lines
1.4 KiB
Diff
39 lines
1.4 KiB
Diff
--- a/arch/mips/ath79/Kconfig
|
|
+++ b/arch/mips/ath79/Kconfig
|
|
@@ -38,6 +38,15 @@ config ATH79_MACH_ALL0258N
|
|
select ATH79_DEV_LEDS_GPIO
|
|
select ATH79_DEV_M25P80
|
|
|
|
+config ATH79_MACH_ALL0315N
|
|
+ bool "Allnet ALL0315N support"
|
|
+ select SOC_AR724X
|
|
+ select ATH79_DEV_AP9X_PCI if PCI
|
|
+ select ATH79_DEV_ETH
|
|
+ select ATH79_DEV_GPIO_BUTTONS
|
|
+ select ATH79_DEV_LEDS_GPIO
|
|
+ select ATH79_DEV_M25P80
|
|
+
|
|
config ATH79_MACH_AP113
|
|
bool "Atheros AP113 board support"
|
|
select SOC_AR724X
|
|
--- a/arch/mips/ath79/Makefile
|
|
+++ b/arch/mips/ath79/Makefile
|
|
@@ -39,6 +39,7 @@ obj-$(CONFIG_ATH79_PCI_ATH9K_FIXUP) += p
|
|
obj-$(CONFIG_ATH79_MACH_ALFA_AP96) += mach-alfa-ap96.o
|
|
obj-$(CONFIG_ATH79_MACH_ALFA_NX) += mach-alfa-nx.o
|
|
obj-$(CONFIG_ATH79_MACH_ALL0258N) += mach-all0258n.o
|
|
+obj-$(CONFIG_ATH79_MACH_ALL0315N) += mach-all0315n.o
|
|
obj-$(CONFIG_ATH79_MACH_AP113) += mach-ap113.o
|
|
obj-$(CONFIG_ATH79_MACH_AP121) += mach-ap121.o
|
|
obj-$(CONFIG_ATH79_MACH_AP136) += mach-ap136.o
|
|
--- a/arch/mips/ath79/machtypes.h
|
|
+++ b/arch/mips/ath79/machtypes.h
|
|
@@ -20,6 +20,7 @@ enum ath79_mach_type {
|
|
ATH79_MACH_ALFA_NX, /* ALFA Network N2/N5 board */
|
|
ATH79_MACH_ALL0258N, /* Allnet ALL0258N */
|
|
ATH79_MACH_ALL0305, /* Allnet ALL0305 */
|
|
+ ATH79_MACH_ALL0315N, /* Allnet ALL0315N */
|
|
ATH79_MACH_AP113, /* Atheros AP113 reference board */
|
|
ATH79_MACH_AP121, /* Atheros AP121 reference board */
|
|
ATH79_MACH_AP121_MINI, /* Atheros AP121-MINI reference board */
|