mirror of https://github.com/hak5/openwrt.git
29 lines
889 B
Diff
29 lines
889 B
Diff
--- a/arch/arm/boot/dts/imx6qdl.dtsi
|
|
+++ b/arch/arm/boot/dts/imx6qdl.dtsi
|
|
@@ -119,7 +119,7 @@
|
|
0x82000000 0 0x01000000 0x01000000 0 0x00f00000>; /* non-prefetchable memory */
|
|
num-lanes = <1>;
|
|
interrupts = <0 123 0x04>;
|
|
- clocks = <&clks 189>, <&clks 187>, <&clks 206>, <&clks 144>;
|
|
+ clocks = <&clks 189>, <&clks 187>, <&clks 198>, <&clks 144>;
|
|
clock-names = "pcie_ref_125m", "sata_ref_100m", "lvds_gate", "pcie_axi";
|
|
status = "disabled";
|
|
};
|
|
--- a/drivers/pci/Kconfig
|
|
+++ b/drivers/pci/Kconfig
|
|
@@ -125,3 +125,5 @@ config PCI_IOAPIC
|
|
config PCI_LABEL
|
|
def_bool y if (DMI || ACPI)
|
|
select NLS
|
|
+
|
|
+source "drivers/pci/host/Kconfig"
|
|
--- a/drivers/pci/Makefile
|
|
+++ b/drivers/pci/Makefile
|
|
@@ -67,3 +67,6 @@ obj-$(CONFIG_XEN_PCIDEV_FRONTEND) += xen
|
|
obj-$(CONFIG_OF) += of.o
|
|
|
|
ccflags-$(CONFIG_PCI_DEBUG) := -DDEBUG
|
|
+
|
|
+# PCI host controller drivers
|
|
+obj-y += host/
|