mirror of https://github.com/hak5/openwrt.git
26 lines
1.1 KiB
Diff
26 lines
1.1 KiB
Diff
diff -urN linux-2.6.19.2/drivers/net/Kconfig linux-2.6.19.2-adm5120/drivers/net/Kconfig
|
|
--- linux-2.6.19.2/drivers/net/Kconfig 2007-01-10 20:10:37.000000000 +0100
|
|
+++ linux-2.6.19.2-adm5120/drivers/net/Kconfig 2007-01-23 01:13:39.000000000 +0100
|
|
@@ -450,6 +450,10 @@
|
|
If you have an Alchemy Semi AU1X00 based system
|
|
say Y. Otherwise, say N.
|
|
|
|
+config MIPS_ADM5120_ENET
|
|
+ tristate "MIPS ADM5120 Ethernet switch support"
|
|
+ depends on NET_ETHERNET && MIPS_ADM5120
|
|
+
|
|
config NET_SB1250_MAC
|
|
tristate "SB1250 Ethernet support"
|
|
depends on NET_ETHERNET && SIBYTE_SB1xxx_SOC
|
|
diff -urN linux-2.6.19.2/drivers/net/Makefile linux-2.6.19.2-adm5120/drivers/net/Makefile
|
|
--- linux-2.6.19.2/drivers/net/Makefile 2007-01-10 20:10:37.000000000 +0100
|
|
+++ linux-2.6.19.2-adm5120/drivers/net/Makefile 2007-01-23 01:13:39.000000000 +0100
|
|
@@ -164,6 +164,7 @@
|
|
# This is also a 82596 and should probably be merged
|
|
obj-$(CONFIG_LP486E) += lp486e.o
|
|
|
|
+obj-$(CONFIG_MIPS_ADM5120_ENET) += adm5120sw.o
|
|
obj-$(CONFIG_ETH16I) += eth16i.o
|
|
obj-$(CONFIG_ZORRO8390) += zorro8390.o 8390.o
|
|
obj-$(CONFIG_HPLANCE) += hplance.o 7990.o
|