mirror of https://github.com/hak5/openwrt.git
65 lines
2.3 KiB
Diff
65 lines
2.3 KiB
Diff
diff -urN linux-2.6.19.2/arch/mips/Kconfig linux-2.6.19.2.new/arch/mips/Kconfig
|
|
--- linux-2.6.19.2/arch/mips/Kconfig 2007-01-10 20:10:37.000000000 +0100
|
|
+++ linux-2.6.19.2.new/arch/mips/Kconfig 2007-01-23 14:49:38.000000000 +0100
|
|
@@ -12,6 +12,18 @@
|
|
prompt "System type"
|
|
default SGI_IP22
|
|
|
|
+config MIPS_ADM5120
|
|
+ bool "Support for ADM5120 SoC"
|
|
+ select SYS_HAS_CPU_MIPS32_R1
|
|
+ select DMA_NONCOHERENT
|
|
+ select HW_HAS_PCI
|
|
+ select SYS_SUPPORTS_LITTLE_ENDIAN
|
|
+ select SYS_SUPPORTS_32BIT_KERNEL
|
|
+
|
|
+config PCI_ADM5120
|
|
+ bool "Add PCI control support for ADM5120"
|
|
+ depends on MIPS_ADM5120 && PCI
|
|
+
|
|
config MIPS_MTX1
|
|
bool "4G Systems MTX-1 board"
|
|
select DMA_NONCOHERENT
|
|
diff -urN linux-2.6.19.2/arch/mips/Makefile linux-2.6.19.2.new/arch/mips/Makefile
|
|
--- linux-2.6.19.2/arch/mips/Makefile 2007-01-23 14:02:57.000000000 +0100
|
|
+++ linux-2.6.19.2.new/arch/mips/Makefile 2007-01-23 14:49:39.000000000 +0100
|
|
@@ -165,6 +165,14 @@
|
|
load-$(CONFIG_MACH_JAZZ) += 0xffffffff80080000
|
|
|
|
#
|
|
+# ADMtek 5120
|
|
+#
|
|
+
|
|
+core-$(CONFIG_MIPS_ADM5120) += arch/mips/adm5120/
|
|
+cflags-$(CONFIG_MIPS_ADM5120) += -Iinclude/asm-mips/mach-adm5120
|
|
+load-$(CONFIG_MIPS_ADM5120) += 0xffffffff80101000
|
|
+
|
|
+#
|
|
# Common Alchemy Au1x00 stuff
|
|
#
|
|
core-$(CONFIG_SOC_AU1X00) += arch/mips/au1000/common/
|
|
diff -urN linux-2.6.19.2/arch/mips/pci/Makefile linux-2.6.19.2.new/arch/mips/pci/Makefile
|
|
--- linux-2.6.19.2/arch/mips/pci/Makefile 2007-01-10 20:10:37.000000000 +0100
|
|
+++ linux-2.6.19.2.new/arch/mips/pci/Makefile 2007-01-23 14:49:40.000000000 +0100
|
|
@@ -53,3 +53,4 @@
|
|
obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc30x.o
|
|
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
|
|
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
|
|
+obj-$(CONFIG_PCI_ADM5120) += ops-adm5120.o pci-adm5120.o
|
|
diff -urN linux-2.6.19.2/include/asm-mips/bootinfo.h linux-2.6.19.2.new/include/asm-mips/bootinfo.h
|
|
--- linux-2.6.19.2/include/asm-mips/bootinfo.h 2007-01-10 20:10:37.000000000 +0100
|
|
+++ linux-2.6.19.2.new/include/asm-mips/bootinfo.h 2007-01-23 14:49:40.000000000 +0100
|
|
@@ -212,6 +212,12 @@
|
|
#define MACH_GROUP_NEC_EMMA2RH 25 /* NEC EMMA2RH (was 23) */
|
|
#define MACH_NEC_MARKEINS 0 /* NEC EMMA2RH Mark-eins */
|
|
|
|
+/*
|
|
+ * Valid machtype for group ADMtek
|
|
+ */
|
|
+#define MACH_GROUP_ADM_GW 23
|
|
+#define MACH_ADM_GW_5120 0
|
|
+
|
|
#define CL_SIZE COMMAND_LINE_SIZE
|
|
|
|
const char *get_system_type(void);
|