mirror of https://github.com/hak5/openwrt.git
30 lines
1006 B
Diff
30 lines
1006 B
Diff
Index: linux-2.6.23.17/drivers/char/watchdog/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.23.17.orig/drivers/char/watchdog/Kconfig
|
|
+++ linux-2.6.23.17/drivers/char/watchdog/Kconfig
|
|
@@ -583,6 +583,12 @@ config SBC_EPX_C3_WATCHDOG
|
|
|
|
# MIPS Architecture
|
|
|
|
+config AR7_WDT
|
|
+ tristate "TI AR7 Watchdog Timer"
|
|
+ depends on WATCHDOG && AR7
|
|
+ help
|
|
+ Hardware driver for the TI AR7 Watchdog Timer.
|
|
+
|
|
config INDYDOG
|
|
tristate "Indy/I2 Hardware Watchdog"
|
|
depends on SGI_IP22
|
|
Index: linux-2.6.23.17/drivers/char/watchdog/Makefile
|
|
===================================================================
|
|
--- linux-2.6.23.17.orig/drivers/char/watchdog/Makefile
|
|
+++ linux-2.6.23.17/drivers/char/watchdog/Makefile
|
|
@@ -87,6 +87,7 @@ obj-$(CONFIG_SBC_EPX_C3_WATCHDOG) += sbc
|
|
# M68KNOMMU Architecture
|
|
|
|
# MIPS Architecture
|
|
+obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
|
obj-$(CONFIG_INDYDOG) += indydog.o
|
|
obj-$(CONFIG_WDT_MTX1) += mtx-1_wdt.o
|
|
obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
|