mirror of https://github.com/hak5/openwrt.git
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
--- a/drivers/mtd/Kconfig
|
|
+++ b/drivers/mtd/Kconfig
|
|
@@ -168,6 +168,22 @@
|
|
the partition map from the children of the flash node,
|
|
as described in Documentation/powerpc/booting-without-of.txt.
|
|
|
|
+config MTD_MYLOADER_PARTS
|
|
+ tristate "MyLoader partition parsing"
|
|
+ depends on MIPS_ADM5120 && MTD_PARTITIONS
|
|
+ ---help---
|
|
+ MyLoader is a bootloader which allows the user to define partitions
|
|
+ in flash devices, by putting a table in the second erase block
|
|
+ on the device, similar to a partition table. This table gives the
|
|
+ offsets and lengths of the user defined partitions.
|
|
+
|
|
+ If you need code which can detect and parse these tables, and
|
|
+ register MTD 'partitions' corresponding to each image detected,
|
|
+ enable this option.
|
|
+
|
|
+ You will still need the parsing functions to be called by the driver
|
|
+ for your particular device. It won't happen automatically.
|
|
+
|
|
comment "User Modules And Translation Layers"
|
|
|
|
config MTD_CHAR
|
|
--- a/drivers/mtd/Makefile
|
|
+++ b/drivers/mtd/Makefile
|
|
@@ -12,6 +12,7 @@
|
|
obj-$(CONFIG_MTD_CMDLINE_PARTS) += cmdlinepart.o
|
|
obj-$(CONFIG_MTD_AFS_PARTS) += afs.o
|
|
obj-$(CONFIG_MTD_OF_PARTS) += ofpart.o
|
|
+obj-$(CONFIG_MTD_MYLOADER_PARTS) += myloader.o
|
|
|
|
# 'Users' - code which presents functionality to userspace.
|
|
obj-$(CONFIG_MTD_CHAR) += mtdchar.o
|