mirror of https://github.com/hak5/openwrt.git
35 lines
1.0 KiB
Diff
35 lines
1.0 KiB
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -25,6 +25,21 @@
|
|
This option enables support for LEDs driven using outputs
|
|
of the dedicated PWM controller found on newer Atmel SOCs.
|
|
|
|
+config LEDS_ADM5120
|
|
+ tristate "LED Support for ADM5120 GPIO LEDs"
|
|
+ depends on LEDS_GPIO && MIPS_ADM5120
|
|
+ help
|
|
+ This option enables support for LEDs connected to GPIO lines
|
|
+ on ADM5120 SoC based platforms.
|
|
+
|
|
+config LEDS_ADM5120_EXPERIMENTAL
|
|
+ bool "Enable ADM5120 LEDs experimental code"
|
|
+ depends on LEDS_ADM5120
|
|
+
|
|
+config LEDS_ADM5120_DIAG
|
|
+ bool "Enable ADM5120 LEDs diagnostic mode"
|
|
+ depends on LEDS_ADM5120
|
|
+
|
|
config LEDS_CORGI
|
|
tristate "LED Support for the Sharp SL-C7x0 series"
|
|
depends on LEDS_CLASS && PXA_SHARP_C7xx
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -5,6 +5,7 @@
|
|
obj-$(CONFIG_LEDS_TRIGGERS) += led-triggers.o
|
|
|
|
# LED Platform Drivers
|
|
+obj-$(CONFIG_LEDS_ADM5120) += leds-adm5120.o
|
|
obj-$(CONFIG_LEDS_ATMEL_PWM) += leds-atmel-pwm.o
|
|
obj-$(CONFIG_LEDS_CORGI) += leds-corgi.o
|
|
obj-$(CONFIG_LEDS_LOCOMO) += leds-locomo.o
|