mirror of https://github.com/hak5/openwrt.git
27 lines
1.0 KiB
Diff
27 lines
1.0 KiB
Diff
Index: linux-2.6.23/drivers/leds/Kconfig
|
|
===================================================================
|
|
--- linux-2.6.23.orig/drivers/leds/Kconfig
|
|
+++ linux-2.6.23/drivers/leds/Kconfig
|
|
@@ -152,4 +152,12 @@ config LEDS_TRIGGER_MORSE
|
|
tristate "LED Morse Trigger"
|
|
depends on LEDS_TRIGGERS
|
|
|
|
+config LEDS_TRIGGER_ADM5120_SWITCH
|
|
+ tristate "LED ADM5120 Switch Port Status Trigger"
|
|
+ depends on LEDS_TRIGGERS && LEDS_ADM5120
|
|
+ help
|
|
+ This allows LEDs to be controlled by the port states of
|
|
+ the ADM5120 built-in Ethernet Switch
|
|
+ If unsure, say N.
|
|
+
|
|
endif # NEW_LEDS
|
|
Index: linux-2.6.23/drivers/leds/Makefile
|
|
===================================================================
|
|
--- linux-2.6.23.orig/drivers/leds/Makefile
|
|
+++ linux-2.6.23/drivers/leds/Makefile
|
|
@@ -24,3 +24,4 @@ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledt
|
|
obj-$(CONFIG_LEDS_TRIGGER_IDE_DISK) += ledtrig-ide-disk.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_HEARTBEAT) += ledtrig-heartbeat.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_ADM5120_SWITCH) += ledtrig-adm5120-switch.o
|