mirror of https://github.com/hak5/openwrt.git
48 lines
1.2 KiB
Diff
48 lines
1.2 KiB
Diff
--- a/arch/mips/Makefile
|
|
+++ b/arch/mips/Makefile
|
|
@@ -603,6 +603,24 @@ else
|
|
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
|
|
endif
|
|
|
|
+#
|
|
+# Ralink SoC common stuff
|
|
+#
|
|
+core-$(CONFIG_MIPS_RALINK) += arch/mips/ralink/common/
|
|
+cflags-$(CONFIG_MIPS_RALINK) += -I$(srctree)/arch/mips/include/asm/mach-ralink
|
|
+
|
|
+#
|
|
+# Ralink RT288x
|
|
+#
|
|
+core-$(CONFIG_RALINK_RT288X) += arch/mips/ralink/rt288x/
|
|
+load-$(CONFIG_RALINK_RT288X) += 0xffffffff88000000
|
|
+
|
|
+#
|
|
+# Ralink RT305x
|
|
+#
|
|
+core-$(CONFIG_RALINK_RT305X) += arch/mips/ralink/rt305x/
|
|
+load-$(CONFIG_RALINK_RT305X) += 0xffffffff80000000
|
|
+
|
|
# temporary until string.h is fixed
|
|
cflags-y += -ffreestanding
|
|
|
|
--- a/arch/mips/Kconfig
|
|
+++ b/arch/mips/Kconfig
|
|
@@ -22,6 +22,9 @@ choice
|
|
config MACH_ALCHEMY
|
|
bool "Alchemy processor based machines"
|
|
|
|
+config MIPS_RALINK
|
|
+ bool "Ralink MIPS SoC based boards"
|
|
+
|
|
config BASLER_EXCITE
|
|
bool "Basler eXcite smart camera"
|
|
select CEVT_R4K
|
|
@@ -638,6 +641,7 @@ source "arch/mips/basler/excite/Kconfig"
|
|
source "arch/mips/jazz/Kconfig"
|
|
source "arch/mips/lasat/Kconfig"
|
|
source "arch/mips/pmc-sierra/Kconfig"
|
|
+source "arch/mips/ralink/Kconfig"
|
|
source "arch/mips/sgi-ip27/Kconfig"
|
|
source "arch/mips/sibyte/Kconfig"
|
|
source "arch/mips/txx9/Kconfig"
|