mirror of https://github.com/hak5/openwrt.git
51 lines
1.5 KiB
Diff
51 lines
1.5 KiB
Diff
--- a/arch/mips/Makefile
|
|
+++ b/arch/mips/Makefile
|
|
@@ -181,6 +181,13 @@ ifeq (,$(findstring march=octeon, $(cfla
|
|
cflags-$(CONFIG_CPU_CAVIUM_OCTEON) += -Wa,-march=octeon
|
|
endif
|
|
|
|
+#
|
|
+# Atheros AR71xx
|
|
+#
|
|
+core-$(CONFIG_ATHEROS_AR71XX) += arch/mips/ar71xx/
|
|
+cflags-$(CONFIG_ATHEROS_AR71XX) += -I$(srctree)/arch/mips/include/asm/mach-ar71xx
|
|
+load-$(CONFIG_ATHEROS_AR71XX) += 0xffffffff80060000
|
|
+
|
|
cflags-$(CONFIG_CPU_R4000_WORKAROUNDS) += $(call cc-option,-mfix-r4000,)
|
|
cflags-$(CONFIG_CPU_R4400_WORKAROUNDS) += $(call cc-option,-mfix-r4400,)
|
|
cflags-$(CONFIG_CPU_DADDI_WORKAROUNDS) += $(call cc-option,-mno-daddi,)
|
|
--- a/arch/mips/Kconfig
|
|
+++ b/arch/mips/Kconfig
|
|
@@ -48,6 +48,23 @@ config AR7
|
|
Support for the Texas Instruments AR7 System-on-a-Chip
|
|
family: TNETD7100, 7200 and 7300.
|
|
|
|
+config ATHEROS_AR71XX
|
|
+ bool "Atheros AR71xx based boards"
|
|
+ select CEVT_R4K
|
|
+ select CSRC_R4K
|
|
+ select DMA_NONCOHERENT
|
|
+ select HW_HAS_PCI
|
|
+ select IRQ_CPU
|
|
+ select ARCH_REQUIRE_GPIOLIB
|
|
+ select SYS_HAS_CPU_MIPS32_R1
|
|
+ select SYS_HAS_CPU_MIPS32_R2
|
|
+ select SYS_SUPPORTS_32BIT_KERNEL
|
|
+ select SYS_SUPPORTS_BIG_ENDIAN
|
|
+ select SYS_HAS_EARLY_PRINTK
|
|
+ select MIPS_MACHINE
|
|
+ help
|
|
+ Support for Atheros AR71xx based boards.
|
|
+
|
|
config BCM47XX
|
|
bool "Broadcom BCM47XX based boards"
|
|
select CEVT_R4K
|
|
@@ -684,6 +701,7 @@ config CAVIUM_OCTEON_REFERENCE_BOARD
|
|
endchoice
|
|
|
|
source "arch/mips/alchemy/Kconfig"
|
|
+source "arch/mips/ar71xx/Kconfig"
|
|
source "arch/mips/bcm63xx/Kconfig"
|
|
source "arch/mips/jazz/Kconfig"
|
|
source "arch/mips/lasat/Kconfig"
|