mirror of https://github.com/hak5/openwrt.git
78 lines
2.8 KiB
Diff
78 lines
2.8 KiB
Diff
diff -urN linux-2.6.24/arch/x86/Kconfig linux-2.6.24.new/arch/x86/Kconfig
|
|
--- linux-2.6.24/arch/x86/Kconfig 2008-01-24 23:58:37.000000000 +0100
|
|
+++ linux-2.6.24.new/arch/x86/Kconfig 2008-02-11 18:24:27.000000000 +0100
|
|
@@ -300,6 +300,17 @@
|
|
supposed to run on these EM64T-based machines. Only choose this option
|
|
if you have one of these machines.
|
|
|
|
+config X86_RDC
|
|
+ bool "Support for RDC 3211 boards"
|
|
+ select GENERIC_GPIO
|
|
+ select LEDS_GPIO
|
|
+ select LEDS_CLASS
|
|
+ help
|
|
+ Support for RDC 3211 systems. Say 'Y' here if the kernel is
|
|
+ supposed to run on an IA-32 RDC R3211 system.
|
|
+ Only choose this option if you have such as system, otherwise you
|
|
+ should say N here.
|
|
+
|
|
endchoice
|
|
|
|
config SCHED_NO_NO_OMIT_FRAME_POINTER
|
|
diff -urN linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c
|
|
--- linux-2.6.24/arch/x86/kernel/reboot_fixups_32.c 2008-01-24 23:58:37.000000000 +0100
|
|
+++ linux-2.6.24.new/arch/x86/kernel/reboot_fixups_32.c 2008-02-11 18:26:18.000000000 +0100
|
|
@@ -30,6 +30,17 @@
|
|
udelay(50); /* shouldn't get here but be safe and spin a while */
|
|
}
|
|
|
|
+static void r8610_reset(struct pci_dev *dev)
|
|
+{
|
|
+ int i;
|
|
+
|
|
+ outl(0x80003840,0xCF8);
|
|
+ i=inl(0xCFC);
|
|
+ i |= 0x1600;
|
|
+ outl(i,0xCFC);
|
|
+ outb(1,0x92);
|
|
+}
|
|
+
|
|
struct device_fixup {
|
|
unsigned int vendor;
|
|
unsigned int device;
|
|
@@ -40,6 +51,7 @@
|
|
{ PCI_VENDOR_ID_CYRIX, PCI_DEVICE_ID_CYRIX_5530_LEGACY, cs5530a_warm_reset },
|
|
{ PCI_VENDOR_ID_AMD, PCI_DEVICE_ID_AMD_CS5536_ISA, cs5536_warm_reset },
|
|
{ PCI_VENDOR_ID_NS, PCI_DEVICE_ID_NS_SC1100_BRIDGE, cs5530a_warm_reset },
|
|
+{ PCI_VENDOR_ID_RDC, PCI_DEVICE_ID_RDC_R6030, r8610_reset },
|
|
};
|
|
|
|
/*
|
|
diff -urN linux-2.6.24/arch/x86/Makefile_32 linux-2.6.24.new/arch/x86/Makefile_32
|
|
--- linux-2.6.24/arch/x86/Makefile_32 2008-01-24 23:58:37.000000000 +0100
|
|
+++ linux-2.6.24.new/arch/x86/Makefile_32 2008-02-11 18:25:12.000000000 +0100
|
|
@@ -99,6 +99,11 @@
|
|
mcore-$(CONFIG_X86_ES7000) := arch/x86/mach-default
|
|
core-$(CONFIG_X86_ES7000) := arch/x86/mach-es7000/
|
|
|
|
+# RDC subarch support
|
|
+mflags-$(CONFIG_X86_RDC) := -Iinclude/asm-x86/mach-rdc
|
|
+mcore-$(CONFIG_X86_RDC) := arch/x86/mach-default
|
|
+core-$(CONFIG_X86_RDC) += arch/x86/mach-rdc/
|
|
+
|
|
# Xen paravirtualization support
|
|
core-$(CONFIG_XEN) += arch/x86/xen/
|
|
|
|
diff -urN linux-2.6.24/include/asm-x86/timex.h linux-2.6.24.new/include/asm-x86/timex.h
|
|
--- linux-2.6.24/include/asm-x86/timex.h 2008-01-24 23:58:37.000000000 +0100
|
|
+++ linux-2.6.24.new/include/asm-x86/timex.h 2008-02-11 18:25:43.000000000 +0100
|
|
@@ -7,6 +7,8 @@
|
|
|
|
#ifdef CONFIG_X86_ELAN
|
|
# define PIT_TICK_RATE 1189200 /* AMD Elan has different frequency! */
|
|
+#elif defined(CONFIG_X86_RDC)
|
|
+# define PIT_TICK_RATE 1041667 /* Underlying HZ for R8610 */
|
|
#else
|
|
# define PIT_TICK_RATE 1193182 /* Underlying HZ */
|
|
#endif
|