mirror of https://github.com/hak5/openwrt.git
24 lines
798 B
Diff
24 lines
798 B
Diff
--- a/arch/arm/mach-orion5x/Kconfig
|
|
+++ b/arch/arm/mach-orion5x/Kconfig
|
|
@@ -16,6 +16,13 @@ config MACH_RD88F5182
|
|
Say 'Y' here if you want your kernel to support the
|
|
Marvell Orion-NAS (88F5182) RD2
|
|
|
|
+config MACH_DT2
|
|
+ bool "Freecom DataTank Gateway"
|
|
+ select I2C_BOARDINFO
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ Freecom DataTank Gateway
|
|
+
|
|
config MACH_KUROBOX_PRO
|
|
bool "KuroBox Pro"
|
|
select I2C_BOARDINFO
|
|
--- a/arch/arm/mach-orion5x/Makefile
|
|
+++ b/arch/arm/mach-orion5x/Makefile
|
|
@@ -21,3 +21,4 @@ obj-$(CONFIG_MACH_WNR854T) += wnr854t-se
|
|
obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
|
|
obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
|
|
obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o
|
|
+obj-$(CONFIG_MACH_DT2) += dt2-setup.o
|