mirror of https://github.com/hak5/openwrt.git
67 lines
2.1 KiB
Diff
67 lines
2.1 KiB
Diff
--- a/arch/arm/mach-kirkwood/Makefile
|
|
+++ b/arch/arm/mach-kirkwood/Makefile
|
|
@@ -8,6 +8,8 @@ obj-$(CONFIG_MACH_SHEEVAPLUG) += sheeva
|
|
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
|
|
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
|
|
obj-$(CONFIG_MACH_DOCKSTAR) += dockstar-setup.o
|
|
+obj-$(CONFIG_MACH_GOFLEXNET) += goflexnet-setup.o
|
|
+obj-$(CONFIG_MACH_GOFLEXHOME) += goflexhome-setup.o
|
|
obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
|
|
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
|
|
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
|
|
@@ -18,5 +20,8 @@ obj-$(CONFIG_MACH_D2NET_V2) += d2net_v2
|
|
obj-$(CONFIG_MACH_NET2BIG_V2) += netxbig_v2-setup.o lacie_v2-common.o
|
|
obj-$(CONFIG_MACH_NET5BIG_V2) += netxbig_v2-setup.o lacie_v2-common.o
|
|
obj-$(CONFIG_MACH_T5325) += t5325-setup.o
|
|
+obj-$(CONFIG_MACH_ICONNECT) += iconnect-setup.o
|
|
+obj-$(CONFIG_MACH_NAS6210) += nas6210-setup.o
|
|
+obj-$(CONFIG_MACH_NSA310) += nsa-310-setup.o
|
|
|
|
obj-$(CONFIG_CPU_IDLE) += cpuidle.o
|
|
--- a/arch/arm/mach-kirkwood/Kconfig
|
|
+++ b/arch/arm/mach-kirkwood/Kconfig
|
|
@@ -64,6 +64,18 @@ config MACH_DOCKSTAR
|
|
Say 'Y' here if you want your kernel to support the
|
|
Seagate FreeAgent DockStar.
|
|
|
|
+config MACH_GOFLEXNET
|
|
+ bool "Seagate GoFlex Net"
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ Seagate GoFlex Net.
|
|
+
|
|
+config MACH_GOFLEXHOME
|
|
+ bool "Seagate GoFlex Home"
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ Seagate GoFlex Home.
|
|
+
|
|
config MACH_OPENRD
|
|
bool
|
|
|
|
@@ -130,6 +142,24 @@ config MACH_T5325
|
|
Say 'Y' here if you want your kernel to support the
|
|
HP t5325 Thin Client.
|
|
|
|
+config MACH_ICONNECT
|
|
+ bool "Iomega iConnect Wireless"
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ Iomega iConnect Wireless.
|
|
+
|
|
+config MACH_NAS6210
|
|
+ bool "RaidSonic ICY BOX IB-NAS6210"
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ RaidSonic ICY BOX IB-NAS6210 device.
|
|
+
|
|
+config MACH_NSA310
|
|
+ bool "ZyXEL NSA-310"
|
|
+ help
|
|
+ Say 'Y' here if you want your kernel to support the
|
|
+ ZyXEL NSA-310 board.
|
|
+
|
|
endmenu
|
|
|
|
endif
|