mirror of https://github.com/hak5/openwrt.git
26 lines
898 B
Diff
26 lines
898 B
Diff
--- a/drivers/spi/Kconfig
|
|
+++ b/drivers/spi/Kconfig
|
|
@@ -214,6 +214,12 @@ config SPI_PXA2XX
|
|
The driver can be configured to use any SSP port and additional
|
|
documentation can be found a Documentation/spi/pxa2xx.
|
|
|
|
+config SPI_RB4XX
|
|
+ tristate "Mikrotik RB4XX SPI master"
|
|
+ depends on SPI_MASTER && AR71XX_MACH_RB4XX
|
|
+ help
|
|
+ SPI controller driver for the Mikrotik RB4xx series boards.
|
|
+
|
|
config SPI_S3C24XX
|
|
tristate "Samsung S3C24XX series SPI"
|
|
depends on ARCH_S3C2410 && EXPERIMENTAL
|
|
--- a/drivers/spi/Makefile
|
|
+++ b/drivers/spi/Makefile
|
|
@@ -33,6 +33,7 @@ obj-$(CONFIG_SPI_S3C24XX_GPIO) += spi_s
|
|
obj-$(CONFIG_SPI_S3C24XX) += spi_s3c24xx.o
|
|
obj-$(CONFIG_SPI_TXX9) += spi_txx9.o
|
|
obj-$(CONFIG_SPI_XILINX) += xilinx_spi.o
|
|
+obj-$(CONFIG_SPI_RB4XX) += rb4xx_spi.o
|
|
obj-$(CONFIG_SPI_SH_SCI) += spi_sh_sci.o
|
|
obj-$(CONFIG_SPI_STMP3XXX) += spi_stmp.o
|
|
# ... add above this line ...
|