mirror of https://github.com/hak5/openwrt.git
40 lines
1.0 KiB
Diff
40 lines
1.0 KiB
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -12,6 +12,16 @@ menuconfig PHYLIB
|
|
|
|
if PHYLIB
|
|
|
|
+config SWCONFIG
|
|
+ tristate "Switch configuration API"
|
|
+ ---help---
|
|
+ Switch configuration API using netlink. This allows
|
|
+ you to configure the VLAN features of certain switches.
|
|
+
|
|
+config SWCONFIG_LEDS
|
|
+ bool "Switch LED trigger support"
|
|
+ depends on (SWCONFIG && LEDS_TRIGGERS)
|
|
+
|
|
comment "MII PHY device drivers"
|
|
|
|
config AT803X_PHY
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -3,6 +3,7 @@
|
|
libphy-objs := phy.o phy_device.o mdio_bus.o
|
|
|
|
obj-$(CONFIG_PHYLIB) += libphy.o
|
|
+obj-$(CONFIG_SWCONFIG) += swconfig.o
|
|
obj-$(CONFIG_MARVELL_PHY) += marvell.o
|
|
obj-$(CONFIG_DAVICOM_PHY) += davicom.o
|
|
obj-$(CONFIG_CICADA_PHY) += cicada.o
|
|
--- a/include/uapi/linux/Kbuild
|
|
+++ b/include/uapi/linux/Kbuild
|
|
@@ -361,6 +361,7 @@ header-y += stddef.h
|
|
header-y += string.h
|
|
header-y += suspend_ioctls.h
|
|
header-y += swab.h
|
|
+header-y += switch.h
|
|
header-y += synclink.h
|
|
header-y += sysctl.h
|
|
header-y += sysinfo.h
|