mirror of https://github.com/hak5/openwrt.git
23 lines
770 B
Diff
23 lines
770 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -431,18 +431,9 @@ else
|
|
depmod_opts := -b $(INSTALL_MOD_PATH) -r
|
|
endif
|
|
.PHONY: _modinst_post
|
|
-_modinst_post: _modinst_post_pcmcia
|
|
+_modinst_post:
|
|
if [ -r System.map ]; then $(DEPMOD) -ae -F System.map $(depmod_opts) $(KERNELRELEASE); fi
|
|
|
|
-# Backwards compatibilty symlinks for people still using old versions
|
|
-# of pcmcia-cs with hard coded pathnames on insmod. Remove
|
|
-# _modinst_post_pcmcia for kernel 2.4.1.
|
|
-.PHONY: _modinst_post_pcmcia
|
|
-_modinst_post_pcmcia:
|
|
- cd $(MODLIB); \
|
|
- mkdir -p pcmcia; \
|
|
- find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} pcmcia
|
|
-
|
|
.PHONY: $(patsubst %, _modinst_%, $(SUBDIRS))
|
|
$(patsubst %, _modinst_%, $(SUBDIRS)) :
|
|
$(MAKE) -C $(patsubst _modinst_%, %, $@) modules_install
|