mirror of https://github.com/hak5/openwrt.git
30 lines
1.0 KiB
Diff
30 lines
1.0 KiB
Diff
From 961a7aeafab477f63d9eef26afde9cbb8badcd0f Mon Sep 17 00:00:00 2001
|
|
From: Peter Ujfalusi <peter.ujfalusi@ti.com>
|
|
Date: Mon, 1 Oct 2012 12:29:26 +0300
|
|
Subject: [PATCH] ASoC: dmaengine: Correct Makefile when sound is built as
|
|
module
|
|
|
|
soc-dmaengine-pcm library need to be part of the snd-soc-core in order to
|
|
be able to compile ASoC as modules when dmaengine is enabled on the platform.
|
|
|
|
Signed-off-by: Peter Ujfalusi <peter.ujfalusi@ti.com>
|
|
Signed-off-by: Mark Brown <broonie@opensource.wolfsonmicro.com>
|
|
---
|
|
sound/soc/Makefile | 5 +++--
|
|
1 file changed, 3 insertions(+), 2 deletions(-)
|
|
|
|
--- a/sound/soc/Makefile
|
|
+++ b/sound/soc/Makefile
|
|
@@ -1,8 +1,9 @@
|
|
snd-soc-core-objs := soc-core.o soc-dapm.o soc-jack.o soc-cache.o soc-utils.o
|
|
snd-soc-core-objs += soc-pcm.o soc-io.o
|
|
|
|
-snd-soc-dmaengine-pcm-objs := soc-dmaengine-pcm.o
|
|
-obj-$(CONFIG_SND_SOC_DMAENGINE_PCM) += snd-soc-dmaengine-pcm.o
|
|
+ifneq ($(CONFIG_SND_SOC_DMAENGINE_PCM),)
|
|
+snd-soc-core-objs += soc-dmaengine-pcm.o
|
|
+endif
|
|
|
|
obj-$(CONFIG_SND_SOC) += snd-soc-core.o
|
|
obj-$(CONFIG_SND_SOC) += codecs/
|