mirror of https://github.com/hak5/openwrt.git
64 lines
2.9 KiB
Diff
64 lines
2.9 KiB
Diff
From 3a5a84cdd1488bad118eeac72d09a60299bca744 Mon Sep 17 00:00:00 2001
|
|
From: Simon Kelley <simon@thekelleys.org.uk>
|
|
Date: Wed, 31 Oct 2018 21:30:13 +0000
|
|
Subject: [PATCH 08/32] Fix Makefile lines generating UBUS linker config.
|
|
|
|
If arg2 of pkg-wrapper is "--copy", then arg1 is NOT the name of
|
|
the package manager (--copy doesn't invoke it) it's a secondary
|
|
config string that inhibts the copy if found. This patch allows that
|
|
to be the empty string, for unconditional copy, and modifies the
|
|
ubus linker config to use it. It worked by coincidence before, because
|
|
there was no config string called "pkg-config".
|
|
|
|
Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
|
|
---
|
|
Makefile | 2 +-
|
|
bld/pkg-wrapper | 14 ++++++++------
|
|
2 files changed, 9 insertions(+), 7 deletions(-)
|
|
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -53,7 +53,7 @@ top?=$(CURDIR)
|
|
|
|
dbus_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_DBUS $(PKG_CONFIG) --cflags dbus-1`
|
|
dbus_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_DBUS $(PKG_CONFIG) --libs dbus-1`
|
|
-ubus_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_UBUS $(PKG_CONFIG) --copy -lubox -lubus`
|
|
+ubus_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_UBUS "" --copy -lubox -lubus`
|
|
idn_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_IDN $(PKG_CONFIG) --cflags libidn`
|
|
idn_libs = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_IDN $(PKG_CONFIG) --libs libidn`
|
|
idn2_cflags = `echo $(COPTS) | $(top)/bld/pkg-wrapper HAVE_LIBIDN2 $(PKG_CONFIG) --cflags libidn2`
|
|
--- a/bld/pkg-wrapper
|
|
+++ b/bld/pkg-wrapper
|
|
@@ -11,23 +11,25 @@ in=`cat`
|
|
|
|
if grep "^\#[[:space:]]*define[[:space:]]*$search" config.h >/dev/null 2>&1 || \
|
|
echo $in | grep $search >/dev/null 2>&1; then
|
|
-# Nasty, nasty, in --copy, arg 2 is another config to search for, use with NO_GMP
|
|
+# Nasty, nasty, in --copy, arg 2 (if non-empty) is another config to search for, used with NO_GMP
|
|
if [ $op = "--copy" ]; then
|
|
- if grep "^\#[[:space:]]*define[[:space:]]*$pkg" config.h >/dev/null 2>&1 || \
|
|
- echo $in | grep $pkg >/dev/null 2>&1; then
|
|
+ if [ -z "$pkg" ]; then
|
|
+ pkg="$*"
|
|
+ elif grep "^\#[[:space:]]*define[[:space:]]*$pkg" config.h >/dev/null 2>&1 || \
|
|
+ echo $in | grep $pkg >/dev/null 2>&1; then
|
|
pkg=""
|
|
else
|
|
pkg="$*"
|
|
fi
|
|
elif grep "^\#[[:space:]]*define[[:space:]]*${search}_STATIC" config.h >/dev/null 2>&1 || \
|
|
- echo $in | grep ${search}_STATIC >/dev/null 2>&1; then
|
|
+ echo $in | grep ${search}_STATIC >/dev/null 2>&1; then
|
|
pkg=`$pkg --static $op $*`
|
|
else
|
|
pkg=`$pkg $op $*`
|
|
fi
|
|
-
|
|
+
|
|
if grep "^\#[[:space:]]*define[[:space:]]*${search}_STATIC" config.h >/dev/null 2>&1 || \
|
|
- echo $in | grep ${search}_STATIC >/dev/null 2>&1; then
|
|
+ echo $in | grep ${search}_STATIC >/dev/null 2>&1; then
|
|
if [ $op = "--libs" ] || [ $op = "--copy" ]; then
|
|
echo "-Wl,-Bstatic $pkg -Wl,-Bdynamic"
|
|
else
|