mirror of https://github.com/hak5/openwrt.git
26 lines
684 B
Diff
26 lines
684 B
Diff
--- a/drivers/watchdog/Kconfig
|
|
+++ b/drivers/watchdog/Kconfig
|
|
@@ -683,6 +683,12 @@ config TXX9_WDT
|
|
help
|
|
Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
|
|
|
|
+config ATHEROS_WDT
|
|
+ tristate "Atheros wisoc Watchdog Timer"
|
|
+ depends on ATHEROS
|
|
+ help
|
|
+ Hardware driver for the Atheros wisoc Watchdog Timer.
|
|
+
|
|
# PARISC Architecture
|
|
|
|
# POWERPC Architecture
|
|
--- a/drivers/watchdog/Makefile
|
|
+++ b/drivers/watchdog/Makefile
|
|
@@ -97,6 +97,7 @@ obj-$(CONFIG_WDT_RM9K_GPI) += rm9k_wdt.o
|
|
obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
|
|
obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
|
|
obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
|
|
+obj-$(CONFIG_ATHEROS_WDT) += ar2315-wtd.o
|
|
|
|
# PARISC Architecture
|
|
|