mirror of https://github.com/hak5/openwrt.git
39 lines
982 B
Diff
39 lines
982 B
Diff
--- a/drivers/base/regmap/Kconfig
|
|
+++ b/drivers/base/regmap/Kconfig
|
|
@@ -3,16 +3,17 @@
|
|
# subsystems should select the appropriate symbols.
|
|
|
|
config REGMAP
|
|
- default y if (REGMAP_I2C || REGMAP_SPI)
|
|
select LZO_COMPRESS
|
|
select LZO_DECOMPRESS
|
|
- bool
|
|
+ tristate "Regmap"
|
|
|
|
config REGMAP_I2C
|
|
- tristate
|
|
+ select REGMAP
|
|
+ tristate "Regmap I2C"
|
|
|
|
config REGMAP_SPI
|
|
- tristate
|
|
+ select REGMAP
|
|
+ tristate "Regmap SPI"
|
|
|
|
config REGMAP_IRQ
|
|
bool
|
|
--- a/drivers/base/regmap/Makefile
|
|
+++ b/drivers/base/regmap/Makefile
|
|
@@ -1,6 +1,8 @@
|
|
-obj-$(CONFIG_REGMAP) += regmap.o regcache.o
|
|
-obj-$(CONFIG_REGMAP) += regcache-rbtree.o regcache-lzo.o
|
|
-obj-$(CONFIG_DEBUG_FS) += regmap-debugfs.o
|
|
+regmap-core-objs = regmap.o regcache.o regcache-rbtree.o regcache-lzo.o
|
|
+ifdef CONFIG_DEBUG_FS
|
|
+regmap-core-objs += regmap-debugfs.o
|
|
+endif
|
|
+obj-$(CONFIG_REGMAP) += regmap-core.o
|
|
obj-$(CONFIG_REGMAP_I2C) += regmap-i2c.o
|
|
obj-$(CONFIG_REGMAP_SPI) += regmap-spi.o
|
|
obj-$(CONFIG_REGMAP_IRQ) += regmap-irq.o
|