mirror of https://github.com/hak5/openwrt.git
21 lines
649 B
Diff
21 lines
649 B
Diff
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -81,6 +81,7 @@ MOSTLYCLEANFILES = yacc
|
|
|
|
yacc:
|
|
$(AM_V_GEN)echo '#! /bin/sh' >$@
|
|
+ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
|
$(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
|
$(AM_V_at)chmod a+x $@
|
|
|
|
--- a/src/Makefile.in
|
|
+++ b/src/Makefile.in
|
|
@@ -1919,6 +1919,7 @@ uninstall-am: uninstall-binPROGRAMS unin
|
|
|
|
yacc:
|
|
$(AM_V_GEN)echo '#! /bin/sh' >$@
|
|
+ $(AM_V_at)echo 'test -n "$$STAGING_DIR" && exec "$$STAGING_DIR/../host/bin/bison" -y "$$@"' >>$@
|
|
$(AM_V_at)echo "exec '$(bindir)/bison' -y "'"$$@"' >>$@
|
|
$(AM_V_at)chmod a+x $@
|
|
|