mirror of https://github.com/hak5/openwrt.git
73 lines
2.0 KiB
Diff
73 lines
2.0 KiB
Diff
--- a/arch/mips/Kconfig
|
|
+++ b/arch/mips/Kconfig
|
|
@@ -78,6 +78,23 @@ config MIPS_COBALT
|
|
select SYS_SUPPORTS_LITTLE_ENDIAN
|
|
select GENERIC_HARDIRQS_NO__DO_IRQ
|
|
|
|
+config IFXMIPS
|
|
+ bool "Infineon Twinpass, Danube, Amazon-SE"
|
|
+ select DMA_NONCOHERENT
|
|
+ select IRQ_CPU
|
|
+ select CEVT_R4K
|
|
+ select CSRC_R4K
|
|
+ select SYS_HAS_CPU_MIPS32_R1
|
|
+ select SYS_HAS_CPU_MIPS32_R2
|
|
+ select HAVE_STD_PC_SERIAL_PORT
|
|
+ select SYS_SUPPORTS_BIG_ENDIAN
|
|
+ select SYS_SUPPORTS_32BIT_KERNEL
|
|
+ select SYS_SUPPORTS_MULTITHREADING
|
|
+ select SYS_HAS_EARLY_PRINTK
|
|
+ select HW_HAS_PCI
|
|
+ select GENERIC_GPIO
|
|
+ select SWAP_IO_SPACE
|
|
+
|
|
config MACH_DECSTATION
|
|
bool "DECstations"
|
|
select BOOT_ELF32
|
|
@@ -607,6 +624,7 @@ source "arch/mips/sgi-ip27/Kconfig"
|
|
source "arch/mips/sibyte/Kconfig"
|
|
source "arch/mips/txx9/Kconfig"
|
|
source "arch/mips/vr41xx/Kconfig"
|
|
+source "arch/mips/ifxmips/Kconfig"
|
|
|
|
endmenu
|
|
|
|
--- a/arch/mips/Makefile
|
|
+++ b/arch/mips/Makefile
|
|
@@ -283,6 +283,13 @@ cflags-$(CONFIG_MIPS_COBALT) += -Iinclud
|
|
load-$(CONFIG_MIPS_COBALT) += 0xffffffff80080000
|
|
|
|
#
|
|
+# Infineon IFXMIPS
|
|
+#
|
|
+core-$(CONFIG_IFXMIPS) += arch/mips/ifxmips/
|
|
+cflags-$(CONFIG_IFXMIPS) += -Iinclude/asm-mips/mach-ifxmips
|
|
+load-$(CONFIG_IFXMIPS) += 0xffffffff80002000
|
|
+
|
|
+#
|
|
# DECstation family
|
|
#
|
|
core-$(CONFIG_MACH_DECSTATION) += arch/mips/dec/
|
|
--- a/include/asm-mips/bootinfo.h
|
|
+++ b/include/asm-mips/bootinfo.h
|
|
@@ -57,6 +57,12 @@
|
|
#define MACH_MIKROTIK_RB532 0 /* Mikrotik RouterBoard 532 */
|
|
#define MACH_MIKROTIK_RB532A 1 /* Mikrotik RouterBoard 532A */
|
|
|
|
+/*
|
|
+ * Valid machtype for group IFXMIPS
|
|
+ */
|
|
+#define MACH_GROUP_IFXMIPS 29
|
|
+#define MACH_INFINEON_IFXMIPS 0
|
|
+
|
|
#define CL_SIZE COMMAND_LINE_SIZE
|
|
|
|
extern char *system_type;
|
|
--- a/arch/mips/pci/Makefile
|
|
+++ b/arch/mips/pci/Makefile
|
|
@@ -51,3 +51,4 @@ obj-$(CONFIG_VICTOR_MPC30X) += fixup-mpc
|
|
obj-$(CONFIG_ZAO_CAPCELLA) += fixup-capcella.o
|
|
obj-$(CONFIG_WR_PPMC) += fixup-wrppmc.o
|
|
obj-$(CONFIG_MIKROTIK_RB532) += pci-rc32434.o ops-rc32434.o fixup-rc32434.o
|
|
+obj-$(CONFIG_IFXMIPS) += pci-ifxmips.o ops-ifxmips.o
|