mirror of https://github.com/hak5/openwrt.git
24 lines
699 B
Diff
24 lines
699 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -76,6 +76,11 @@
|
|
---help---
|
|
Currently supports the Marvell 88E6060 switch.
|
|
|
|
+config MICREL_PHY
|
|
+ tristate "Drivers for Micrel/Kendin PHYs"
|
|
+ ---help---
|
|
+ Currently has a driver for the KSZ8041
|
|
+
|
|
config FIXED_PHY
|
|
bool "Driver for MDIO Bus/PHY emulation with fixed speed/link PHYs"
|
|
depends on PHYLIB=y
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -15,5 +15,6 @@
|
|
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
|
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
|
+obj-$(CONFIG_MICREL_PHY) += micrel.o
|
|
obj-$(CONFIG_FIXED_PHY) += fixed.o
|
|
obj-$(CONFIG_MDIO_BITBANG) += mdio-bitbang.o
|