mirror of https://github.com/hak5/openwrt.git
25 lines
790 B
Diff
25 lines
790 B
Diff
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -62,6 +62,11 @@ config BROADCOM_PHY
|
|
Currently supports the BCM5411, BCM5421, BCM5461, BCM5464, BCM5481
|
|
and BCM5482 PHYs.
|
|
|
|
+config BROADCOM5222_PHY
|
|
+ tristate "Drivers for Broadcom5222 PHY"
|
|
+ ---help---
|
|
+ Currently supports the BCM5222 PHYs.
|
|
+
|
|
config ICPLUS_PHY
|
|
tristate "Drivers for ICPlus PHYs"
|
|
---help---
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -12,6 +12,7 @@ obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
|
obj-$(CONFIG_SMSC_PHY) += smsc.o
|
|
obj-$(CONFIG_VITESSE_PHY) += vitesse.o
|
|
obj-$(CONFIG_BROADCOM_PHY) += broadcom.o
|
|
+obj-$(CONFIG_BROADCOM5222_PHY) += broadcom522x.o
|
|
obj-$(CONFIG_ICPLUS_PHY) += icplus.o
|
|
obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
|
obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|