mirror of https://github.com/hak5/openwrt.git
22 lines
708 B
Diff
22 lines
708 B
Diff
--- a/drivers/leds/Kconfig
|
|
+++ b/drivers/leds/Kconfig
|
|
@@ -299,4 +299,11 @@ config LEDS_TRIGGER_MORSE
|
|
tristate "LED Morse Trigger"
|
|
depends on LEDS_TRIGGERS
|
|
|
|
+config LEDS_TRIGGER_NETDEV
|
|
+ tristate "LED Netdev Trigger"
|
|
+ depends on NET && LEDS_TRIGGERS
|
|
+ help
|
|
+ This allows LEDs to be controlled by network device activity.
|
|
+ If unsure, say Y.
|
|
+
|
|
endif # NEW_LEDS
|
|
--- a/drivers/leds/Makefile
|
|
+++ b/drivers/leds/Makefile
|
|
@@ -39,3 +39,4 @@ obj-$(CONFIG_LEDS_TRIGGER_BACKLIGHT) +=
|
|
obj-$(CONFIG_LEDS_TRIGGER_GPIO) += ledtrig-gpio.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_DEFAULT_ON) += ledtrig-default-on.o
|
|
obj-$(CONFIG_LEDS_TRIGGER_MORSE) += ledtrig-morse.o
|
|
+obj-$(CONFIG_LEDS_TRIGGER_NETDEV) += ledtrig-netdev.o
|